Added APPCATEGORY so a .desktop file will be installed
authorJim Ramsay <lack@gentoo.org>
Wed, 31 Jan 2007 00:12:12 +0000 (00:12 +0000)
committerJim Ramsay <lack@gentoo.org>
Wed, 31 Jan 2007 00:12:12 +0000 (00:12 +0000)
Package-Manager: portage-2.1.2-r4

rox-extra/musicbox/ChangeLog
rox-extra/musicbox/files/digest-musicbox-027-r1 [new file with mode: 0644]
rox-extra/musicbox/musicbox-027-r1.ebuild [new file with mode: 0644]
rox-extra/picky/ChangeLog
rox-extra/picky/files/digest-picky-0.4.5-r1 [new file with mode: 0644]
rox-extra/picky/picky-0.4.5-r1.ebuild [new file with mode: 0644]

index c106e79f5fcc7a16e236eb27b78772dc5c1f84ad..2b9ed584b8bbab78c1ba9152dcb17330cb830d42 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for rox-extra/musicbox
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/ChangeLog,v 1.6 2006/11/20 18:25:57 opfer Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/ChangeLog,v 1.7 2007/01/31 00:10:58 lack Exp $
+
+*musicbox-027-r1 (31 Jan 2007)
+
+  31 Jan 2007; Jim Ramsay <lack@gentoo.org> +musicbox-027-r1.ebuild:
+  Added APPCATEGORY so a .desktop file will be installed
 
   20 Nov 2006; Christian Faulhammer <opfer@gentoo.org> musicbox-027.ebuild:
   stable x86, bug #155521
diff --git a/rox-extra/musicbox/files/digest-musicbox-027-r1 b/rox-extra/musicbox/files/digest-musicbox-027-r1
new file mode 100644 (file)
index 0000000..b79e1e2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ebeeab6c35362856314138a6e3638de8 MusicBox-027.tgz 110634
+RMD160 c6cfbc09b0fbdafd3677f6de391bd20878e5d330 MusicBox-027.tgz 110634
+SHA256 a1a4897ec42f10cfcaaf59990212fe68a83744d5938473d0e560b6c608fd0015 MusicBox-027.tgz 110634
diff --git a/rox-extra/musicbox/musicbox-027-r1.ebuild b/rox-extra/musicbox/musicbox-027-r1.ebuild
new file mode 100644 (file)
index 0000000..9d77e04
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/musicbox-027-r1.ebuild,v 1.1 2007/01/31 00:10:58 lack Exp $
+
+ROX_LIB_VER=2.0.0
+inherit rox eutils
+
+DESCRIPTION="MusicBox - an MP3/OGG Player for the ROX Desktop"
+HOMEPAGE="http://www.hayber.us/rox/MusicBox/"
+SRC_URI="http://www.hayber.us/rox/musicbox/MusicBox-027.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mp3 vorbis flac alsa"
+
+DEPEND="
+       >=dev-python/pyao-0.81
+       alsa? ( >=dev-python/pyalsaaudio-0.2 )
+       mp3? (
+               >=dev-python/pymad-0.4.1
+               >=dev-python/pyid3lib-0.5.1 )
+       vorbis? ( >=dev-python/pyvorbis-1.1 )
+       flac? (
+               ~media-libs/flac-1.1.2
+               >=dev-lang/swig-1.3.25 )"
+
+RDEPEND="
+       >=dev-python/pyao-0.81
+       alsa? ( >=dev-python/pyalsaaudio-0.2 )
+       mp3? (
+               >=dev-python/pymad-0.4.1
+               >=dev-python/pyid3lib-0.5.1 )
+       vorbis? ( >=dev-python/pyvorbis-1.1 )
+       flac? ( >=media-libs/flac-1.1.2 )"
+
+APPNAME=MusicBox
+APPCATEGORY="AudioVideo;Audio;Player"
+S=${WORKDIR}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       if use flac; then
+               if ! built_with_use dev-lang/swig python; then
+                       einfo "MusicBox flac support requires swig with python support."
+                       einfo "Please rebuild swig with USE=\"python\"."
+                       die "swig python support missing"
+               fi
+               epatch ${FILESDIR}/${P}-fPIC.patch
+       fi
+       epatch ${FILESDIR}/${P}-mime.patch
+}
+
+# Special compilation needed for flac support
+src_compile() {
+       if use flac; then
+               cd "${S}/${APPNAME}/plugins/flac"
+               make || die "flac plugin compile failed."
+       fi
+       rox_src_compile
+}
+
index e15724052e4a9f5a480dc52fb90087e218a1a93f..5d24b24af7c474c18d61331f97043e30bde1a587 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for rox-extra/picky
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-extra/picky/ChangeLog,v 1.8 2006/11/20 18:26:45 opfer Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/picky/ChangeLog,v 1.9 2007/01/31 00:12:12 lack Exp $
+
+*picky-0.4.5-r1 (31 Jan 2007)
+
+  31 Jan 2007; Jim Ramsay <lack@gentoo.org> +picky-0.4.5-r1.ebuild:
+  Added APPCATEGORY so a .desktop file will be installed
 
   20 Nov 2006; Christian Faulhammer <opfer@gentoo.org> picky-0.4.5.ebuild:
   stable x86, bug #155521
diff --git a/rox-extra/picky/files/digest-picky-0.4.5-r1 b/rox-extra/picky/files/digest-picky-0.4.5-r1
new file mode 100644 (file)
index 0000000..1d0b7ab
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9b87b85cbfd36b844a16fb096d36fa64 Picky-0.4.5.tar.bz2 21912
+RMD160 bdc9b9d2c1b611ea1d7341d92a1e97462073deff Picky-0.4.5.tar.bz2 21912
+SHA256 52944e7be864625a9f24f9db6d17442fdab683e891a5103ac326561cb625151e Picky-0.4.5.tar.bz2 21912
diff --git a/rox-extra/picky/picky-0.4.5-r1.ebuild b/rox-extra/picky/picky-0.4.5-r1.ebuild
new file mode 100644 (file)
index 0000000..dfafc1a
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/picky/picky-0.4.5-r1.ebuild,v 1.1 2007/01/31 00:12:12 lack Exp $
+
+ROX_LIB_VER=1.9.12
+inherit rox
+
+DESCRIPTION="Picky - an image viewer/slideshow app for the ROX Desktop"
+MY_PN="Picky"
+HOMEPAGE="http://www.rdsarts.com/code/picky/"
+SRC_URI="http://www.rdsarts.com/code/picky/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+
+APPNAME=${MY_PN}
+APPCATEGORY="Graphics;Viewer"
+
+src_unpack() {
+       mkdir -p ${S}/${APPNAME}
+       cd ${S}/${APPNAME}
+       unpack ${A}
+}