gnome-extra/pch-session: Bump to 3.34.2
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Mar 2020 17:53:52 +0000 (18:53 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Mar 2020 17:54:20 +0000 (18:54 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
gnome-extra/pch-session/Manifest
gnome-extra/pch-session/pch-session-3.34.2.ebuild [new file with mode: 0644]

index 16daf18a6f8ea6aa383d43d14bb0002b7fd280de..f1f2f5a34e86967471f17b7be7502c3d8adec1b3 100644 (file)
@@ -1,2 +1,3 @@
 DIST pch-session-3.32.0.tar.bz2 8940 BLAKE2B f7b96486fda4b38e0c548b950d60cafc7f150dc8c3f1e671f04d070b937e6f9ae753db6bfc5a81061c107483dbec752ebc85515133f8a62235b3c68c51091474 SHA512 32d6393ef74cea1a7eff3e5361732f3ac47ef1ae993c33bd17a3629f1491c129ea043688dbce11dfa331d4cbe89395966b98f58c1806502a9ffcdaa62c303e91
 DIST pch-session-3.34.1.tar.bz2 9144 BLAKE2B a85f7d9b3498883d0117c232a5b9c3e0b594e43efa076086f51cffd51267de98ca01a8ceb4dbb173b39d671dc8dbfb32cdfddd0ac38c50eba6c0906a6a577b8d SHA512 8da75282673f4a11240b94865c6b834aaf44e5545877789cb1c8d66ec67a3ad3609f2c2992a59ec083a9c70ee231cb4e96daf89828cb58a99420756708d93055
+DIST pch-session-3.34.2.tar.bz2 9196 BLAKE2B 19313aafb18cd66372e64db5825e4fc50e091aa64fb276676a4c0dbabeaa73be191741112042a716a5472e174b1b7b6248251265b35e3dfb7d2bbc41500d6d6f SHA512 23da344cc9103dfdadf7cb8a7dcd9082b5e6440e7a04c3f1b9cdeb8ec15f79328990d7478cbf3093794b85c62b3615af605e020506cc78bff251d6e36c2ffda9
diff --git a/gnome-extra/pch-session/pch-session-3.34.2.ebuild b/gnome-extra/pch-session/pch-session-3.34.2.ebuild
new file mode 100644 (file)
index 0000000..2092efd
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Unofficial gnome based session with different default settings and extensions"
+HOMEPAGE="https://gitlab.com/pachoramos/pch-session"
+SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# gnome-extra/gnome-tweaks to configure extensions easily
+RDEPEND="
+       >=gnome-base/gnome-shell-3.34
+       >=gnome-extra/gnome-shell-extensions-3.34
+       >=gnome-extra/gnome-shell-extension-applications-overview-tooltip-6
+       >=gnome-extra/gnome-shell-extension-bluetooth-quick-connect-10
+       >=gnome-extra/gnome-shell-extension-dash-to-panel-26
+       >=gnome-extra/gnome-shell-extension-desktop-icons-19.10.2
+       >=gnome-extra/gnome-shell-extension-gsconnect-33
+       >=gnome-extra/gnome-shell-extensions-topicons-plus-22_p20190929
+       >=gnome-extra/gnome-tweaks-3.32
+"
+BDEPEND=""
+DEPEND=""
+
+src_install() {
+       insinto /usr
+       doins -r usr/.
+       einstalldocs
+}
+
+pkg_postinst() {
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       gnome2_schemas_update
+}