dev-python/pexpect: Enable py3.8
authorMichał Górny <mgorny@gentoo.org>
Sat, 16 Nov 2019 09:13:31 +0000 (10:13 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 16 Nov 2019 11:01:10 +0000 (12:01 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pexpect/pexpect-4.6.0.ebuild

index d5596edcb12c3887771ec08fe4d2a631b7c38e2f..9a8c5e55861b676b87ad9444bb272397bed1e656 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
@@ -15,21 +15,18 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
+IUSE="doc examples"
 
 RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
 DEPEND="
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+       doc? ( dev-python/sphinx )"
+
+distutils_enable_tests pytest
 
 python_compile_all() {
        use doc && emake -C doc html
 }
 
-python_test() {
-       pytest -vv tests || die "Tests fail with ${EPYTHON}"
-}
-
 python_install_all() {
        use doc && local HTML_DOCS=( doc/_build/html/. )
        if use examples; then