dev-ml/ppx_deriving: initial import; ebuild by me
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 15:02:10 +0000 (16:02 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_deriving/Manifest [new file with mode: 0644]
dev-ml/ppx_deriving/metadata.xml [new file with mode: 0644]
dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ppx_deriving/Manifest b/dev-ml/ppx_deriving/Manifest
new file mode 100644 (file)
index 0000000..58d9aa2
--- /dev/null
@@ -0,0 +1 @@
+DIST ppx_deriving-3.0.tar.gz 38560 SHA256 1998607e68b35b6c61e1fb33c03b523f3bf88f802df6d5bf180dc6932317179b SHA512 1b8ef40fd1b85df0d5307edcc46c16ae1834aadb1419d92dced4b2b542f51bb24999abcdf725647f1f7033ca2df4dc88ab156002b1e6a7a6a83a5e0e4854d833 WHIRLPOOL cda0c6afc31c6d39dd4974c2ce63d28ddea2019bb8bc1c50338c1005880a0a0ef66c2ceb00e86a6a7040c042778f1216321cda3d1dcfc2327c6e084f0ab45b53
diff --git a/dev-ml/ppx_deriving/metadata.xml b/dev-ml/ppx_deriving/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild b/dev-ml/ppx_deriving/ppx_deriving-3.0.ebuild
new file mode 100644 (file)
index 0000000..933139f
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/whitequark/ppx_deriving"
+SRC_URI="https://github.com/whitequark/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt test"
+
+DEPEND="dev-ml/ppx_tools:=
+       >=dev-lang/ocaml-4.02.3:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+       test? ( dev-ml/ounit )"
+
+src_compile() {
+       cp pkg/META.in pkg/META || die
+       ocaml pkg/build.ml \
+               native=$(usex ocamlopt true false) \
+               native-dynlink=$(usex ocamlopt true false) \
+               || die
+       use doc && emake doc
+}
+
+src_test() {
+       ocamlbuild -j 0 -use-ocamlfind -classic-display \
+                       src_test/test_ppx_deriving.byte -- || die
+       if use ocamlopt;  then
+               ocamlbuild -j 0 -use-ocamlfind -classic-display \
+                       src_test/test_ppx_deriving.native -- || die
+       fi
+}
+
+src_install() {
+       findlib_src_preinst
+       # Copied from upstream makefile
+       grep -E '^[[:space:]]+' ppx_deriving.install | \
+               awk '{ print $1 }' | \
+               sed -e 's:"?*::g'  | \
+               xargs ocamlfind install ppx_deriving || die
+
+       use doc && dohtml api.docdir/*
+
+       dodoc CHANGELOG.md README.md
+}