dev-libs/libreport: fix Python install
authorAaron Bauman <bman@gentoo.org>
Wed, 23 May 2018 22:29:11 +0000 (18:29 -0400)
committerAaron Bauman <bman@gentoo.org>
Wed, 23 May 2018 22:30:22 +0000 (18:30 -0400)
This fixes the Python installation when Python USE is enabled.  Also,
drop ltprune eclass and strip .la files properly.

Package-Manager: Portage-2.3.38, Repoman-2.3.9
RepoMan-Options: --force

dev-libs/libreport/libreport-2.9.5.ebuild

index fab10399795b07a7c6ba0e1b59d287b47e80c109..c9250a6e69a36469e96be405cfd7a3ffc8956e82 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 PYTHON_COMPAT=( python3_{4,5,6} )
 
-inherit autotools ltprune python-r1 user
+inherit autotools python-r1 user
 
 DESCRIPTION="Generic library for reporting software bugs"
 HOMEPAGE="https://github.com/abrt/libreport"
@@ -39,6 +39,7 @@ DEPEND="${COMMON_DEPEND}
        app-text/asciidoc
        app-text/xmlto
        >=dev-util/intltool-0.3.50
+       sys-apps/systemd
        >=sys-devel/gettext-0.17
        virtual/pkgconfig
 "
@@ -66,15 +67,23 @@ src_configure() {
                --without-python2
                $(usex python "--with-python3" "--without-python3")
        )
+       if use python; then
+               python_foreach_impl run_in_build_dir \
+                       econf "${myargs[@]}"
+       else
+               econf "${myargs[@]}"
+       fi
+}
 
-       econf "${myargs[@]}"
+src_compile() {
+       use python && python_foreach_impl run_in_build_dir default
 }
 
 src_install() {
-
+       use python && python_foreach_impl run_in_build_dir default
        # Need to set correct ownership for use by app-admin/abrt
        diropts -o abrt -g abrt
        keepdir /var/spool/abrt
 
-       prune_libtool_files --modules
+       find "${D}" -name '*.la' -exec rm -f {} + || die
 }