sys-devel/llvm: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:47 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:50 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/llvm/llvm-10.0.0.9999.ebuild
sys-devel/llvm/llvm-9.0.1.9999.ebuild

index 77a6c8423834164889168c93c8c4ee0c4a926ea9..c5cd658cd7b03188e35f08db6eca2557567c20b9 100644 (file)
@@ -14,8 +14,8 @@ inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm
 
 # Those are in lib/Targets, without explicit CMakeLists.txt mention
 ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -91,6 +91,11 @@ python_check_deps() {
        has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' llvm
+}
+
 check_live_ebuild() {
        local prod_targets=(
                $(sed -n -e '/set(LLVM_ALL_TARGETS/,/)/p' CMakeLists.txt \
index 5ff9e20d7e1220ae8b5f5a8d9f2521dc878379a8..45e29fba1c7b3adc7a4314d3e236242865580cb1 100644 (file)
@@ -14,9 +14,9 @@ inherit cmake-utils git-r3 multilib-minimal multiprocessing pax-utils \
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm
 
 # Keep in sync with CMakeLists.txt
 ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -88,6 +88,11 @@ python_check_deps() {
        has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' llvm
+}
+
 src_prepare() {
        # Fix llvm-config for shared linking and sane flags
        # https://bugs.gentoo.org/show_bug.cgi?id=565358