dev-ros/rospack: Bump to 2.4.0. Update deps.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 25 Feb 2017 08:58:20 +0000 (09:58 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 25 Feb 2017 09:54:48 +0000 (10:54 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/rospack/Manifest
dev-ros/rospack/rospack-2.4.0.ebuild [new file with mode: 0644]
dev-ros/rospack/rospack-9999.ebuild

index bbb8893a0cde9ab26f61ba2580c0638c398b16bb..6167c667acacac78f232207057b47c9a6d1a332b 100644 (file)
@@ -1,2 +1,3 @@
 DIST rospack-2.3.1.tar.gz 70994 SHA256 69634b2fc717903919cd1a7c2367b395b4297676a4aadf0b71bd4d386e50f583 SHA512 647ec1f10fe5f68ba8fe975df54cbafab694605ad30f5f3a02e80d1f5421969fbb94cc047c12ba7e9a395318091ce3bd973ecfed787d02666e27b8c58b655a2d WHIRLPOOL 0ac1f8b4b173576bf8c7d5c17e59b30ef5028a75964e1937e8dd0b601d934a815bdb7c259f8c0c36a1dae3f2a1934a39549d14d30eab77489ab2883da53e9b19
 DIST rospack-2.3.2.tar.gz 71750 SHA256 39f7daeab29fce85237bc1f398fc7623f1eead65c8a2608ee3be0c74bf5462ca SHA512 a040ada1ffdd757f3b08f9dd38546cd2697160b3f3fad94a6c8b662f9285d635c496de7fb7e4dd2081725fb06666f0505ebcbeb761d0d7ca074939d4ab848828 WHIRLPOOL aee0ea9ee3c356b23ee879b89901466de0cd21919e44251828fd3cc88bf490516edc06dfccf01a67aff01f20242e06ed2dccc7836595434a79b7471a37cf383e
+DIST rospack-2.4.0.tar.gz 71908 SHA256 417f4ffbcb1969daf9d72a1ba3eef0cd5da4546e94594add4aee1bc2a2bbc8c2 SHA512 540a74e87a7463dd2fe63904e82d61afdcfbda7715481040b958c29fc48cf8b70af63545f6977fe2641d0f69f257e38320852aa08c22b1395b02a3f61b8c4746 WHIRLPOOL dc0fa1f1395464a5ccbf6d899af37a4caba2123523b10c5a4b9a9e7892a248778a1eecb1ae9201878856edba3846e800752ec1620f359f332b53563888f7f4eb
diff --git a/dev-ros/rospack/rospack-2.4.0.ebuild b/dev-ros/rospack/rospack-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..fadaa0c
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+# Do it that way to avoid ros-catkin pulling in python-r1
+PYTHON_COMPAT=( python{2_7,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+RDEPEND="dev-libs/boost:=
+       dev-libs/tinyxml2:=
+       "
+DEPEND="${RDEPEND}
+       dev-ros/cmake_modules
+       test? (
+               dev-cpp/gtest
+               dev-python/nose
+       )"
index 61b544e45a9257097bfeeb0edddc05eeb010b329..fadaa0c3cfcd076c5615a220004543a28fcda100 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -20,7 +20,7 @@ IUSE=""
 PATCHES=( "${FILESDIR}/gentoo.patch" )
 
 RDEPEND="dev-libs/boost:=
-       dev-libs/tinyxml
+       dev-libs/tinyxml2:=
        "
 DEPEND="${RDEPEND}
        dev-ros/cmake_modules