Initial import. fixes bug #78664
authorJan Brinkmann <luckyduck@gentoo.org>
Wed, 19 Jan 2005 19:43:52 +0000 (19:43 +0000)
committerJan Brinkmann <luckyduck@gentoo.org>
Wed, 19 Jan 2005 19:43:52 +0000 (19:43 +0000)
Package-Manager: portage-2.0.51-r12

dev-java/jdictrayapi/ChangeLog [new file with mode: 0644]
dev-java/jdictrayapi/Manifest [new file with mode: 0644]
dev-java/jdictrayapi/files/0.8.7-gentoo.patch [new file with mode: 0644]
dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.7 [new file with mode: 0644]
dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild [new file with mode: 0644]
dev-java/jdictrayapi/metadata.xml [new file with mode: 0644]

diff --git a/dev-java/jdictrayapi/ChangeLog b/dev-java/jdictrayapi/ChangeLog
new file mode 100644 (file)
index 0000000..e33cba9
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/jdictrayapi
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/ChangeLog,v 1.1 2005/01/19 19:43:52 luckyduck Exp $
+
+*jdictrayapi-0.8.7 (19 Jan 2005)
+
+  19 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org> +metadata.xml,
+  +files/0.8.7-gentoo.patch, +jdictrayapi-0.8.7.ebuild:
+  Initial import, ebuild based on the contribution by Petteri Räty
+  <petteri.raty@welho.com>. Fixes bug #78664.
+
diff --git a/dev-java/jdictrayapi/Manifest b/dev-java/jdictrayapi/Manifest
new file mode 100644 (file)
index 0000000..90ce115
--- /dev/null
@@ -0,0 +1,5 @@
+MD5 8c58fc4c6fcbc55c526980dfb67b296a ChangeLog 488
+MD5 b33389393b46858f60e15d60161f72e0 metadata.xml 834
+MD5 a6431b4af87b274824f40c7f21403126 jdictrayapi-0.8.7.ebuild 1485
+MD5 1970d31723d2629acdf909e4ecef05f0 files/digest-jdictrayapi-0.8.7 63
+MD5 9040a69edf0c8fe2af2c995957231c13 files/0.8.7-gentoo.patch 762
diff --git a/dev-java/jdictrayapi/files/0.8.7-gentoo.patch b/dev-java/jdictrayapi/files/0.8.7-gentoo.patch
new file mode 100644 (file)
index 0000000..5ebac0a
--- /dev/null
@@ -0,0 +1,27 @@
+--- build.xml.orig     2005-01-19 20:14:35.648341416 +0100
++++ build.xml  2005-01-19 20:25:17.164816088 +0100
+@@ -585,4 +585,24 @@
+     <copy file="${unix.native.jni.dir}/libtray.so" todir="${dist.dir}" />
+   </target>
++
++   <target name="sourcezip">
++      <zip destfile="../jdictrayapi-src.zip">
++              <zipfileset dir="src" />
++        </zip>
++   </target>
++
++
++   <!-- generate javadocs -->
++   <target name="docs" depends="init">
++   <mkdir dir="../docs" />
++   <javadoc sourcepath="src/unix/classes"
++              packagenames="org.*"
++                destdir="../docs"
++                author="true"
++                version="true"
++                use="true"
++              source="1.4"
++                windowtitle="${ant.project.name} API" />
++    </target>
+ </project>
diff --git a/dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.7 b/dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.7
new file mode 100644 (file)
index 0000000..78389ba
--- /dev/null
@@ -0,0 +1 @@
+MD5 94e8e959486f68e9f6ca9da8b7c0c7c8 jdic-0.8.7-src.zip 994154
diff --git a/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild b/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild
new file mode 100644 (file)
index 0000000..737398f
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild,v 1.1 2005/01/19 19:43:52 luckyduck Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="The JDesktop Integration Components (JDIC) tray icon API"
+HOMEPAGE="https://jdic.dev.java.net/"
+
+SRC_URI="https://jdic.dev.java.net/files/documents/880/9849/jdic-${PV}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+MY_P="jdic"
+S="${WORKDIR}/${MY_P}-${PV}-src/${MY_P}"
+
+IUSE="doc examples jikes source"
+DEPEND=">=virtual/jdk-1.4
+               >=dev-java/ant-core-1.5.4
+               jikes? ( >=dev-java/jikes-1.21 )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       epatch ${FILESDIR}/${PV}-gentoo.patch
+
+       for dir in $(find . -name CVS);
+       do
+               rm -rf ${dir}
+       done
+}
+
+src_compile() {
+       local antflags="buildtray"
+       use doc && antflags="${antflags} docs"
+       use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+       ant ${antflags} || die "ant build failed"
+}
+
+src_install() {
+       cd ${WORKDIR}/${MY_P}-${PV}-src/
+       dodoc COPYING
+       java-pkg_dohtml README.html
+
+       cd ${S}/dist/linux
+       java-pkg_dojar jdic.jar
+       java-pkg_doso libtray.so
+
+       if use doc; then
+               java-pkg_dohtml -r docs/*
+       fi
+       if use source; then
+               dodir /usr/share/doc/${PF}/source
+               cp ${PN}-src.zip ${D}/usr/share/doc/${PF}/source
+       fi
+       if use examples; then
+               dodir /usr/share/doc/${PF}/examples
+               cp -r ${S}/demo/* ${D}/usr/share/doc/${PF}/examples
+       fi
+}
diff --git a/dev-java/jdictrayapi/metadata.xml b/dev-java/jdictrayapi/metadata.xml
new file mode 100644 (file)
index 0000000..4e8a9b1
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+ The JDesktop Integration Components (JDIC) project aims to make Java™ technology-based applications ("Java applications") first-class citizens of current desktop platforms without sacrificing platform independence.
+
+JDIC provides Java applications with access to facilities provided by the native desktop such as the mailer, the browser, and registered document viewing applications. Additionally it provides the mechanisms by which Java applications can integrate into the native desktop such as registering Java applications as document viewers on the desktop, creating tray icons on the desktop, and creating installer packages. 
+
+</longdescription>
+</pkgmetadata>