dev-python/dnspython: Fix dual source locations,
authorJustin Lecher <jlec@gentoo.org>
Wed, 16 Sep 2015 12:49:45 +0000 (14:49 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 16 Sep 2015 12:52:15 +0000 (14:52 +0200)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=560628

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/dnspython/dnspython-1.12.0-r1.ebuild
dev-python/dnspython/metadata.xml

index a472b313adde5c661da68a2e92b9f711110ae56c..450cb034094373445ccd7a4f1acc928adfccd07a 100644 (file)
@@ -12,7 +12,8 @@ P3="${PN3}-${PV}"
 
 DESCRIPTION="DNS toolkit for Python"
 HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
-SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz
+SRC_URI="
+       http://www.dnspython.org/kits/${PV}/${P}.tar.gz
        http://www.dnspython.org/kits3/${PV}/${P3}.zip"
 
 LICENSE="ISC"
@@ -30,39 +31,40 @@ S3="${WORKDIR}/${P3}"
 # For testsuite
 DISTUTILS_IN_SOURCE_BUILD=1
 
-python_prepare() {
+s_locator() {
        if python_is_python3; then
-               cp -r "${WORKDIR}/${P3}" "${BUILD_DIR}" || die
+               einfo "Setting \${S} to ${S3}"
+               S="${S3}" $@
        else
-               distutils-r1_python_prepare
+               einfo "Setting \${S} to ${S2}"
+               S="${S2}" $@
        fi
 }
 
+python_prepare() {
+       s_locator distutils-r1_python_prepare
+}
+
 python_compile() {
-       if python_is_python3; then
-               run_in_build_dir distutils-r1_python_compile
-       else
-               distutils-r1_python_compile
-       fi
+       s_locator distutils-r1_python_compile
 }
 
 python_install(){
-       if python_is_python3; then
-               run_in_build_dir distutils-r1_python_install
-       else
-               distutils-r1_python_install
-       fi
+       s_locator distutils-r1_python_install
 }
 
-python_test() {
-       if python_is_python3; then
-               pushd "${S3}/tests" &> /dev/null
-       else
-               pushd "${S2}/tests" &> /dev/null
-       fi
+my_test() {
+       pushd tests &> /dev/null
        "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
        einfo "Testsuite passed under ${EPYTHON}"
-       popd &> /dev/null
+}
+
+python_test() {
+       s_locator my_test
+}
+
+python_install() {
+       s_locator distutils-r1_python_install
 }
 
 python_install_all() {
index e593ae87a7c5a5d10df3dc7533d422ad2569bf75..1342021856b7c6aa6345b65dec1c9649503f2742 100644 (file)
@@ -1,8 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>python</herd>
-<longdescription>
+       <herd>python</herd>
+       <longdescription>
 dnspython is a DNS toolkit for Python. It supports almost all of the record
 types. It can be used for queries, zone transfers, and dynamic updates. It
 supports TSIG authenticated messages and EDNS0.  dnspython provides both high
@@ -10,7 +10,7 @@ and low level access to DNS. The high level classes perform queries for data
 of a given name, type, and class, and return an answer set. The low level
 classes allow direct manipulation of DNS zones, messages, names, and records.
 </longdescription>
-<longdescription lang="ja">
+       <longdescription lang="ja">
 DNSPythonはPython言語用のDNSツールキットです。ほとんどのレコード・タイプをサポー
 トします。クエリー、ゾーン・トランスファー、ダイナミック・アップデートができます
 。TSTGメッセージ認証とEDNS0をサポートします。DNSPythonは高水準でのアクセスと低水