dev-java/gson: Version bump to 2.6.2
authorJames Le Cuirot <chewi@gentoo.org>
Tue, 10 May 2016 22:07:06 +0000 (23:07 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 11 May 2016 21:06:22 +0000 (22:06 +0100)
~x86 keyword added.

Package-Manager: portage-2.2.28

dev-java/gson/Manifest
dev-java/gson/gson-2.6.2.ebuild [new file with mode: 0644]

index 9b20f017bdadd0e98e1db7b836ac9aa405599029..330b70b424898ff9f3953a5efb764ce15195d78a 100644 (file)
@@ -1 +1,2 @@
 DIST gson-2.3.1-sources.jar 139924 SHA256 2f2bfe44fad034b526caeb600f3cfca056a143c6c9fbd239f5cbcae4e862b8fa SHA512 a0423c03358a1d843806bc9367b1a328c147973247abfa47b956ab0409ae9542199f6402feb93155761fe538e5d0a79a095b8dad3ccd203c5be81e88713469ba WHIRLPOOL 2f5372c63c43b2ca60a329a33b456db64c4baa1a57186b0e01bcbd3454391b1d79cf26614df66eda40dbc1fa29a4da570d5b575ddab135ae17d47f5de96aa3ff
+DIST gson-parent-2.6.2.tar.gz 434949 SHA256 b33ca70ee634a17e9b95651ea76cf5b0d9c1b5fb6e227a5a1d763513dcfd6d6d SHA512 e4288b60ffaa3773e8025eb8b80ce08f44a197ebdc0ae767e20ed7b514fbc553abd2eea6eea7f949c01f780632273bb55f08fe1947475797b2135e2046cafaf5 WHIRLPOOL 5f11df1b3dcea2fd77b2d6343b980d9bece31c8b8ab65b059508c496fabb80f79f2dcfb1095d1674e387168ec595c7312a210f91915f85b4c7864a59a65bdea3
diff --git a/dev-java/gson/gson-2.6.2.ebuild b/dev-java/gson/gson-2.6.2.ebuild
new file mode 100644 (file)
index 0000000..d20579b
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}-parent-${PV}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library to convert JSON to Java objects and vice-versa"
+HOMEPAGE="https://github.com/google/gson"
+SRC_URI="https://github.com/google/${PN}/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.6"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+JAVA_SRC_DIR="${PN}/src/main/java"