x11-libs/libdockapp: add USE=static-libs
authorBernard Cafarelli <voyageur@gentoo.org>
Sat, 30 May 2020 10:29:25 +0000 (12:29 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sat, 30 May 2020 10:29:38 +0000 (12:29 +0200)
Closes: https://bugs.gentoo.org/726144
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-libs/libdockapp/libdockapp-0.7.2-r3.ebuild [new file with mode: 0644]

diff --git a/x11-libs/libdockapp/libdockapp-0.7.2-r3.ebuild b/x11-libs/libdockapp/libdockapp-0.7.2-r3.ebuild
new file mode 100644 (file)
index 0000000..d612e81
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools font
+
+DESCRIPTION="Window Maker Dock Applet Library"
+HOMEPAGE="https://www.dockapps.net/libdockapp"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+# X equired for font eclass
+IUSE="+X static-libs"
+REQUIRED_USE="X"
+
+RDEPEND="x11-libs/libX11
+       x11-libs/libXt
+       x11-libs/libXext
+       x11-libs/libXpm"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto"
+
+FONT_S=${S}/fonts
+FONT_SUFFIX="gz"
+DOCS="README ChangeLog NEWS AUTHORS"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_prepare()
+{
+       default
+       eautoreconf
+}
+
+src_configure()
+{
+       # Font installation handled by font eclass
+       econf \
+               $(use_enable static-libs static) \
+               --without-font \
+               --without-examples
+}
+
+src_install()
+{
+       emake DESTDIR="${D}" install
+       font_src_install
+}