sys-apps/secilc: Bump to 2.5 release
authorSven Vermeulen <swift@gentoo.org>
Sun, 13 Mar 2016 18:57:05 +0000 (19:57 +0100)
committerSven Vermeulen <swift@gentoo.org>
Sun, 13 Mar 2016 19:46:40 +0000 (20:46 +0100)
Package-Manager: portage-2.2.26

sys-apps/secilc/Manifest [new file with mode: 0644]
sys-apps/secilc/secilc-2.5.ebuild [new file with mode: 0644]
sys-apps/secilc/secilc-9999.ebuild

diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
new file mode 100644 (file)
index 0000000..7fea235
--- /dev/null
@@ -0,0 +1 @@
+DIST secilc-2.5.tar.gz 174642 SHA256 4303d911c06ee5c207e00f778ca786c1a6efa2554a562f5d014dbc0d2f4cc4a4 SHA512 7f7b6fb72bee7018f7a591e6a7d8f58a81ed0e1ec914e0792ccd57a550756a5e21c6359e35ad2fe29225a0bd352637d01288721de3b95a9a175bb3ab052620b9 WHIRLPOOL e674039433041f527a1346ad64887254fa4d7f37f3125b08edcf1e16e23f1d40e1b1151cf6e10d4875d849c43a6b39af0069185303f23b5f331b39c1433deb0e
diff --git a/sys-apps/secilc/secilc-2.5.ebuild b/sys-apps/secilc/secilc-2.5.ebuild
new file mode 100644 (file)
index 0000000..9b5d6da
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20160223"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+       S="${WORKDIR}/${MY_P}/${PN}"
+else
+       SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       app-text/xmlto
+       >=sys-libs/libsepol-${SEPOL_VER}
+       "
+RDEPEND="
+       >=sys-libs/libsepol-${SEPOL_VER}
+       "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+       epatch_user
+}
index b463377b308fce498b0a05669e58881d37432f30..9b5d6dac018d7c7933d609e5ecc55c172584f72f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -7,7 +7,7 @@ EAPI="5"
 inherit toolchain-funcs eutils
 
 MY_P="${P//_/-}"
-MY_RELEASEDATE="20150202"
+MY_RELEASEDATE="20160223"
 
 SEPOL_VER="${PV}"