x11-plugins/wmlpq: EAPI bump, fix compilation with new libdockapp
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 23 Aug 2015 20:16:59 +0000 (22:16 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 23 Aug 2015 20:35:01 +0000 (22:35 +0200)
Package-Manager: portage-2.2.20.1

x11-plugins/wmlpq/Manifest
x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
x11-plugins/wmlpq/wmlpq-0.2.1-r3.ebuild [new file with mode: 0644]

index 0a81bce5f30ee101e1f6a0745a9728ff5b42c9ce..79aba3c19fd34eb2e2fa9b2bafb04df263b6e6bd 100644 (file)
@@ -1 +1 @@
-DIST wmlpq_0.2.1.tar.gz 15180 SHA256 6dba6ed7b61baa6060f4646a230477970dec2fd06d01dab7dbdf064bed348e83
+DIST wmlpq_0.2.1.tar.gz 15180 SHA256 6dba6ed7b61baa6060f4646a230477970dec2fd06d01dab7dbdf064bed348e83 SHA512 757dc6f63d13f4715de7acf4cd436514de96ca78f7eb0e32f156c3a5f75c59e7e9c3d300a81bc1ce8e5def8a66f7678ca7b4b77969ef62f231c9db578c91ce4a WHIRLPOOL 383eab5a697937f510557687ef110d564d7dde701a73b8f3f2d6c32c3fb3e4fe4284aeb59971f3260852a9d261fe4a8048c7b9415fe692cb867456f7f0b97e6b
index c081a49b95d2c774572144052be2581383860853..3f993c19d0b994d699d3669c31f18aa5ade66063 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -10,7 +10,8 @@ DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
 SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
 HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
 
-DEPEND="x11-libs/libdockapp"
+DEPEND="<x11-libs/libdockapp-0.7"
+RDEPEND="${DEPEND}"
 
 RDEPEND=""
 
index 25aba7a574f88d4d99fea0c3cda6a31e25aaefde..83515e265e297cdcc715f4e2d11cf526e3314d27 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -10,7 +10,8 @@ DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
 SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
 HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
 
-DEPEND="x11-libs/libdockapp"
+DEPEND="<x11-libs/libdockapp-0.7"
+RDEPEND="${DEPEND}"
 
 RDEPEND=""
 
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r3.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r3.ebuild
new file mode 100644 (file)
index 0000000..6cb65d6
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
+HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
+SRC_URI="http://www.ur.uklinux.net/${PN}/dl/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+RDEPEND="${DEPEND}"
+
+src_prepare()
+{
+       epatch "${FILESDIR}/${PN}-makefile-ldflags.patch"
+
+       sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile()
+{
+       emake CC=$(tc-getCC) LDFLAGS="${LDFLAGS}"
+}
+
+src_install()
+{
+       dodir /usr/bin
+       emake DESTDIR="${D}"/usr/bin install
+
+       dodoc README sample.wmlpqrc
+       newman wmlpq.1x wmlpq.1
+
+       domenu "${FILESDIR}/${PN}.desktop"
+}