dev-python/defcon: Drop python2 support
authorPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 20:01:34 +0000 (21:01 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 21:28:51 +0000 (22:28 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/defcon/defcon-0.6.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/defcon/defcon-0.6.0-r1.ebuild b/dev-python/defcon/defcon-0.6.0-r1.ebuild
new file mode 100644 (file)
index 0000000..61979f9
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/typesupply/defcon"
+SRC_URI="https://github.com/typesupply/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+python_test() {
+       esetup.py test
+}