dev-python/sure: add py37 support to 1.2.5-r1
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Apr 2019 03:33:46 +0000 (22:33 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Apr 2019 05:07:27 +0000 (00:07 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/sure/sure-1.2.5-r1.ebuild

index fa76a8a27c7ec0437100764805fa51cc2b764812..f26b681d02036c1bb5a8ef2c82090bea1efd390b 100644 (file)
@@ -1,11 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1 vcs-snapshot
+inherit distutils-r1
 
 DESCRIPTION="Utility belt for automated testing in python for python"
 HOMEPAGE="https://github.com/gabrielfalcao/sure"
@@ -26,8 +25,6 @@ DEPEND="
 "
 RDEPEND="${CDEPEND}"
 
-S="${WORKDIR}/${P}-r1"
-
 python_prepare_all() {
        sed \
                -e "82s/read_version()/'${PV}'/" \