dev-python/flask: git-2->git-r3, unify ebuilds
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 27 Apr 2018 18:08:51 +0000 (13:08 -0500)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Apr 2018 10:29:23 +0000 (12:29 +0200)
dev-python/flask-9999 does not install properly due to flask/json not
being found, issue exists without my changes as well.

Package-Manager: Portage-2.3.31, Repoman-2.3.9

dev-python/flask/flask-0.12.2.ebuild
dev-python/flask/flask-9999.ebuild

index 498dd328b2fed7b309c8fa279c9f963df6645883..a6175a6ac4c99006f555f3aed8b055a87cc0e79e 100644 (file)
@@ -7,30 +7,33 @@ PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
 
 inherit distutils-r1
 
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
 DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
 HOMEPAGE="https://github.com/pallets/flask/"
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+       KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+       S="${WORKDIR}/${MY_P}"
+fi
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
 IUSE="doc examples test"
 
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
-       >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
-       >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/click-2[${PYTHON_USEDEP}]
+       >=dev-python/blinker-1[${PYTHON_USEDEP}]
        >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
-       >=dev-python/click-2[${PYTHON_USEDEP}]"
+       >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+       >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 
-S="${WORKDIR}/${MY_P}"
-
 python_prepare_all() {
        # Prevent un-needed d'loading
        sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
index 0b68b4717e591a05a33a5abd6925adbd359fd4bc..3329ccaa5a94b43939e413b973eff89f65ce732f 100644 (file)
@@ -1,43 +1,49 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+EAPI=6
 
-inherit distutils-r1 git-2
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
 
-EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+inherit distutils-r1
 
 DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="https://pypi.org/project/Flask/"
 MY_PN="Flask"
 MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://pypi.org/project/Flask/"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+       S="${WORKDIR}/${MY_P}"
+fi
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="examples test"
+IUSE="doc examples test"
 
 RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
        >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
        >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 
-S="${WORKDIR}/${MY_P}"
-#if LIVE
-SRC_URI=
-KEYWORDS=
-#endif
+python_compile_all() {
+       use doc && emake -C docs html
+}
 
 python_test() {
        py.test tests || die "Testing failed with ${EPYTHON}"
 }
 
 python_install_all() {
-       use examples && local EXAMPLES=( examples/. )
+       use examples && dodoc -r examples
+       use doc && HTML_DOCS=( docs/_build/html/. )
+
        distutils-r1_python_install_all
 }