app-vim/tasklist: Add tasklist vim plugin to the tree.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 22 Aug 2016 08:55:28 +0000 (10:55 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 22 Aug 2016 08:56:28 +0000 (10:56 +0200)
Gentoo-Bug: https://bugs.gentoo.org/336437

Package-Manager: portage-2.2.28

app-vim/tasklist/Manifest [new file with mode: 0644]
app-vim/tasklist/metadata.xml [new file with mode: 0644]
app-vim/tasklist/tasklist-1.0.1.ebuild [new file with mode: 0644]

diff --git a/app-vim/tasklist/Manifest b/app-vim/tasklist/Manifest
new file mode 100644 (file)
index 0000000..7a55c61
--- /dev/null
@@ -0,0 +1 @@
+DIST tasklist-1.0.1.tar.gz 4066 SHA256 70c676e71d3fe6f98ff99b2ad9df64ed8b7ae2f526dd83f5fe938e521170c603 SHA512 623ec5b147e485abe3e246796a6ed67dd8325ef37708e589c4568897da10ba70076eb5dffd9fb9333fc29d045c316cf382950de13f616873334fc734875600b9 WHIRLPOOL 4d59eaad371860a2a3d8fff861ee663b4fbcb40e80e3f14d29c386d64938b063228b12e13a67869d7f1ef24736c75bb652215add39c749b370f75c8ed74472ba
diff --git a/app-vim/tasklist/metadata.xml b/app-vim/tasklist/metadata.xml
new file mode 100644 (file)
index 0000000..8fafbfe
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>monsieurp@gentoo.org</email>
+               <name>Patrice Clement</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>vim@gentoo.org</email>
+               <name>Gentoo Vim Project</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/app-vim/tasklist/tasklist-1.0.1.ebuild b/app-vim/tasklist/tasklist-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..958d173
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="Highlight FIXME/TODO/CUSTOM keywords in a separate list"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2607"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+       default
+       mv vim-* "${P}" || die
+}