dev-python/httpretty: Remove redis tests
authorMichał Górny <mgorny@gentoo.org>
Fri, 15 May 2020 07:22:40 +0000 (09:22 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 15 May 2020 07:27:05 +0000 (09:27 +0200)
The redis tests causes a dependency on dev-python/redis-py
but it is skipped anyway due to requiring a running redis server.

Closes: https://bugs.gentoo.org/722724
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/httpretty/httpretty-1.0.2-r1.ebuild

index eb33b6f3b1d32f9ae4635ff2df4b4faff57337fc..e2bb7e42bf116bacc7ceebbedde86ad0c81c63e9 100644 (file)
@@ -37,6 +37,9 @@ python_prepare_all() {
        sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
        # tests requiring network access
        rm tests/functional/test_passthrough.py || die
+       # requires running redis server
+       # it is skipped correctly but it causes unnecessary dep on redis-py
+       rm tests/functional/bugfixes/test_redis.py || die
 
        distutils-r1_python_prepare_all
 }