app-editors/shed: update to EAPI 7
authorAkinori Hattori <hattya@gentoo.org>
Fri, 13 Dec 2019 12:58:43 +0000 (21:58 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Fri, 13 Dec 2019 13:02:26 +0000 (22:02 +0900)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-editors/shed/shed-1.15.ebuild

index 6d1bfdeb8c3d1deccdbea8309bfc4f47ea11e874..3ab48acb1d19b616872ca10e1ee7e0a926623157 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit autotools eutils
+EAPI="7"
+
+inherit autotools
 
 DESCRIPTION="Simple Hex EDitor"
 HOMEPAGE="http://shed.sourceforge.net/"
@@ -13,15 +14,17 @@ SLOT="0"
 KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
 
 RDEPEND="sys-libs/ncurses:0="
-DEPEND="
-       ${RDEPEND}
-       virtual/pkgconfig
-"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-cflags.patch
+       "${FILESDIR}"/${P}-interix.patch
+       "${FILESDIR}"/${P}-tinfo.patch
+)
 
 src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-cflags.patch \
-               "${FILESDIR}"/${P}-interix.patch \
-               "${FILESDIR}"/${P}-tinfo.patch
+       default
+
+       mv configure.{in,ac} || die
        eautoreconf
 }