media-libs/libilbc: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 16:43:01 +0000 (18:43 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 16:43:01 +0000 (18:43 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libilbc/libilbc-2.0.2.ebuild

index 40eb6ee13b7218de54e566e367d1393f947368c9..d01615a69b31d80b1329a273a4263314b79086a9 100644 (file)
@@ -1,19 +1,18 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-if [[ ${PV} == 9999 ]] ; then
-       SCM="autotools git-2"
+inherit multilib-minimal
+
+if [[ ${PV} == *9999 ]]; then
+       inherit autotools git-r3
        EGIT_REPO_URI="https://github.com/TimothyGu/${PN}"
-       SRC_URI=""
 else
        SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.bz2"
        KEYWORDS="amd64 arm arm64 ppc ppc64 ~sparc x86"
 fi
 
-inherit eutils multilib ${SCM} autotools-multilib
-
 DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
 HOMEPAGE="https://github.com/TimothyGu/libilbc"
 
@@ -21,8 +20,21 @@ LICENSE="BSD"
 SLOT="0"
 IUSE="static-libs"
 
+PATCHES=( "${FILESDIR}"/${PN}-2.0.2-ppc_ppc64_sparc.patch )
+
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-2.0.2-ppc_ppc64_sparc.patch
+       default
        [[ ${PV} == *9999 ]] && eautoreconf
-       autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+       einstalldocs
+
+       # package provides .pc files
+       find "${D}" -name '*.la' -delete || die
 }