dev-python/pytest-shutil: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:21:36 +0000 (15:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:37:52 +0000 (15:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-shutil/pytest-shutil-1.7.0.ebuild

index d7a72037c4a9a12c842ad6c852ab76c970b3e297..701c5f8395ec58c4ce77146079f5d00efe1b1e60 100644 (file)
@@ -2,6 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
 
 inherit distutils-r1
@@ -14,6 +16,7 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,8 +32,6 @@ BDEPEND="
        ${RDEPEND}
 "
 
-RESTRICT="!test? ( test )"
-
 python_prepare_all() {
        # keeps trying to install this in tests
        sed -i 's:path.py::' setup.py || die