games-strategy/freeorion: Switch to python-single-r1 from python-any-r1
authorNP-Hardass <NP-Hardass@gentoo.org>
Mon, 4 Dec 2017 17:39:51 +0000 (12:39 -0500)
committerNP-Hardass <NP-Hardass@gentoo.org>
Fri, 8 Dec 2017 00:35:17 +0000 (19:35 -0500)
Package-Manager: Portage-2.3.14, Repoman-2.3.6

games-strategy/freeorion/freeorion-0.4.7.1-r2.ebuild [moved from games-strategy/freeorion/freeorion-0.4.7.1-r1.ebuild with 92% similarity]
games-strategy/freeorion/freeorion-9999.ebuild

similarity index 92%
rename from games-strategy/freeorion/freeorion-0.4.7.1-r1.ebuild
rename to games-strategy/freeorion/freeorion-0.4.7.1-r2.ebuild
index d0d5447656d7f3b8ef6fee2388ed8f055d129ab3..59dd595f13e846dd83f32a18a2388be773565a3c 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-any-r1 gnome2-utils
+inherit cmake-utils python-single-r1 gnome2-utils
 
 DESCRIPTION="A free turn-based space empire and galactic conquest game"
 HOMEPAGE="http://www.freeorion.org"
@@ -24,7 +24,7 @@ SLOT="0"
 IUSE=""
 
 RDEPEND="
-       >=dev-libs/boost-1.56:=[python,threads]
+       >=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
        media-libs/freealut
        media-libs/freetype
        media-libs/glew:*
@@ -46,7 +46,7 @@ DEPEND="${RDEPEND}
 
 pkg_setup() {
        # build system is using FindPythonLibs.cmake which needs python:2
-       python-any-r1_pkg_setup
+       python-single-r1_pkg_setup
 }
 
 src_prepare() {
index d0d5447656d7f3b8ef6fee2388ed8f055d129ab3..59dd595f13e846dd83f32a18a2388be773565a3c 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-any-r1 gnome2-utils
+inherit cmake-utils python-single-r1 gnome2-utils
 
 DESCRIPTION="A free turn-based space empire and galactic conquest game"
 HOMEPAGE="http://www.freeorion.org"
@@ -24,7 +24,7 @@ SLOT="0"
 IUSE=""
 
 RDEPEND="
-       >=dev-libs/boost-1.56:=[python,threads]
+       >=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
        media-libs/freealut
        media-libs/freetype
        media-libs/glew:*
@@ -46,7 +46,7 @@ DEPEND="${RDEPEND}
 
 pkg_setup() {
        # build system is using FindPythonLibs.cmake which needs python:2
-       python-any-r1_pkg_setup
+       python-single-r1_pkg_setup
 }
 
 src_prepare() {