mail-client/alpine: make PAM optional
authorRobert Siebeck <gentoo.2019@r123.de>
Sat, 17 Nov 2018 18:27:32 +0000 (19:27 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 7 Nov 2019 05:42:29 +0000 (07:42 +0200)
Closes: https://bugs.gentoo.org/617924

Signed-off-by: Robert Siebeck <gentoo.bugzilla.2012@r123.de>
Closes: https://github.com/gentoo/gentoo/pull/10645
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
mail-client/alpine/alpine-2.21.1-r2.ebuild [new file with mode: 0644]
mail-client/alpine/files/alpine-2.21.1-nopam.patch [new file with mode: 0644]

diff --git a/mail-client/alpine/alpine-2.21.1-r2.ebuild b/mail-client/alpine/alpine-2.21.1-r2.ebuild
new file mode 100644 (file)
index 0000000..cd41686
--- /dev/null
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="https://www.washington.edu/alpine/ https://repo.or.cz/alpine.git/"
+GIT_COMMIT="843b2f16abfd949e09b1c5465387b1b0f724994a"
+MY_P="${PN}-${GIT_COMMIT::7}"
+SRC_URI="https://repo.or.cz/alpine.git/snapshot/${GIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine pam passfile smime spell ssl threads"
+
+DEPEND=">=sys-libs/ncurses-5.1:0=
+       kerberos? ( app-crypt/mit-krb5 )
+       ldap? ( net-nds/openldap )
+       pam? ( sys-libs/pam )
+       spell? ( app-text/aspell )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+"
+RDEPEND="${DEPEND}
+       app-misc/mime-types
+"
+
+HTML_DOCS=("doc/tech-notes/")
+
+PATCHES=(
+       "${FILESDIR}/${P}-nopam.patch"
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       myconf=(
+               --without-tcl
+               --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+               --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+               $(use_with ldap)
+               $(use_with ssl)
+               $(use_with passfile passfile .pinepwd)
+               $(use_with kerberos krb5)
+               $(use_with threads pthread)
+               $(use_with spell interactive-spellcheck /usr/bin/aspell)
+               $(use_enable nls)
+               $(use_with ipv6)
+               $(use_with smime)
+               $(use_with pam)
+       )
+
+       if use ssl; then
+               myconf+=(
+                       --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+                       --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+                       --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+               )
+       fi
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+       if use onlyalpine ; then
+               dobin alpine/alpine
+               doman doc/man1/alpine.1
+       else
+               emake -j1 DESTDIR="${D}" install
+               doman doc/man1/*.1
+       fi
+
+       dodoc NOTICE README*
+
+       if use doc ; then
+               dodoc doc/brochure.txt
+
+               dodoc doc/tech-notes/tech-notes.txt
+               newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+               newdoc "${S}/doc/mime.types" mime.types.sample
+               docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+       fi
+}
diff --git a/mail-client/alpine/files/alpine-2.21.1-nopam.patch b/mail-client/alpine/files/alpine-2.21.1-nopam.patch
new file mode 100644 (file)
index 0000000..1552f44
--- /dev/null
@@ -0,0 +1,27 @@
+--- ./configure.ac     2019-11-04 20:09:50.094172283 +0100
++++ ./configure.ac     2019-11-04 20:59:33.775007247 +0100
+@@ -257,6 +257,7 @@
+   alpine_c_client_gccoptlevel="-O0"
+   AC_MSG_RESULT([no])
+ fi
++AC_ARG_WITH([pam], AS_HELP_STRING([--without-pam], [Build without PAM support]))
+ dnl disable mouse support
+ AC_MSG_CHECKING([option: mouse support enabled])
+@@ -1108,7 +1109,7 @@
+       alpine_PAM="yes"
+     else
+       systype="LNX"
+-      AC_CHECK_LIB(pam, pam_start,
++      AS_IF(test "x$with_pam" != "xno",
+         [
+           alpine_c_client_target="lnp"
+         alpine_PAM="yes"
+@@ -1119,6 +1120,7 @@
+         else
+           alpine_c_client_target="lnx"
+         fi
++        alpine_PAM="none"
+         ])
+     fi
+     ;;