app-emulation/runc: remove src_prepare function
authorWilliam Hubbs <william.hubbs@sony.com>
Wed, 4 Mar 2020 17:06:57 +0000 (11:06 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Wed, 4 Mar 2020 17:07:25 +0000 (11:07 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-emulation/runc/runc-1.0.0_rc10.ebuild

index 2338fa34630c1b755d53f880a2e8863d1af8e89c..00d4ecb746d0ffd0da71f4167ca3feb0c92dc9e0 100644 (file)
@@ -31,17 +31,6 @@ RDEPEND="
        !app-emulation/docker-runc
 "
 
-src_prepare() {
-       pushd src/${EGO_PN}
-       default
-       sed -i -e "/^GIT_BRANCH/d"\
-               -e "/^GIT_BRANCH_CLEAN/d"\
-               -e "/^COMMIT_NO/d"\
-               -e "s/COMMIT :=.*/COMMIT := ${RUNC_COMMIT}/"\
-               Makefile || die
-       popd || die
-}
-
 src_compile() {
        # Taken from app-emulation/docker-1.7.0-r1
        export CGO_CFLAGS="-I${ROOT}/usr/include"
@@ -56,7 +45,8 @@ src_compile() {
                $(usex kmem '' 'nokmem')
        )
 
-       GOPATH="${S}" emake BUILDTAGS="${options[*]}" -C src/${EGO_PN}
+       COMMIT=${RUNC_COMMIT} GOPATH="${S}" emake BUILDTAGS="${options[*]}" \
+               -C src/${EGO_PN}
 }
 
 src_install() {