media-sound/linuxsampler: fixed linuxsampler-2.0.0-lv2-automagic.patch
authorMiroslav Šulc <fordfrog@gentoo.org>
Sat, 14 Dec 2019 12:53:31 +0000 (13:53 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Sat, 14 Dec 2019 13:01:40 +0000 (14:01 +0100)
the patch unfortunately changed the logic of lv2 detection
and broke it in such way that it worked with lv2-1.14.0 but
did not work with lv2-1.16.0 so the patch had to be fixed

Closes: https://bugs.gentoo.org/701606
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/linuxsampler/files/linuxsampler-2.0.0-lv2-automagic.patch

index a5b9f8d71efaf58b1a5a29a94b312d5973e91902..522882abf5c42f461da4965d52eca57090357800 100644 (file)
@@ -1,6 +1,8 @@
---- linuxsampler-2.0.0/configure.ac
-+++ linuxsampler-2.0.0/configure.ac
-@@ -532,12 +532,12 @@
+diff --git a/configure.ac b/configure.ac
+index c0a37e9..44348ad 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -535,12 +535,15 @@ AC_CHECK_HEADERS(dssi.h,
  AM_CONDITIONAL(HAVE_DSSI, test $config_have_dssi = "yes")
  
  # LV2
 +      AS_HELP_STRING([--enable-lv2], [Enable building with lv2]))
 +config_have_lv2="no"
 +AS_IF([test "x$enable_lv2" = "xyes"], [
-+      PKG_CHECK_MODULES([LV2], [lv2 >= 1.0.0 lv2core >= 1.0.0], [config_have_lv2="yes"])
++      PKG_CHECK_MODULES(LV2, lv2 >= 1.0.0, config_have_lv2="yes", config_have_lv2="no")
++      if test "$config_have_lv2" != "yes"; then
++          PKG_CHECK_MODULES(LV2, lv2core >= 1.0.0, config_have_lv2="yes", config_have_lv2="no")
++      fi
 +])
  AM_CONDITIONAL(HAVE_LV2, test $config_have_lv2 = "yes")