dev-python/yapsy: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:33:01 +0000 (14:33 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:33:01 +0000 (14:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/yapsy/Manifest
dev-python/yapsy/yapsy-1.11.223-r2.ebuild [deleted file]

index 1701f9d56477fb8e1a1d820e90a4bdbd371d5069..64feaa44261a047a8c2bc9b18f2e29feeeeaa4fd 100644 (file)
@@ -1,2 +1 @@
-DIST Yapsy-1.11.223.tar.gz 80783 BLAKE2B 44f1224f66a35e3ff01d0fb0cf1e0c46fe7932d6fe2ddbaf1c7eed72b7324d8e9fba7be2d32cbec93f33a6d3779b17eb979af751778f672bbffc1119c912e30d SHA512 690d0ab78eafede5a75cf7b7bbcfce00b05c7b6f958980c3b67815bcaf848a8098b6e81afd1d95c5821fa4bb7affefab2cde208ff7c8ac7952615c8ddbafe305
 DIST Yapsy-1.12.2.tar.gz 83986 BLAKE2B e6a2650383a7f0c9bf72d4abf21fffb2abcfdc4115a2a1578a2987b7eef1fc04de9099947c1b9dd510d54a89d9b11f86ac0ca3b13510c6417e94ff92dfec12b6 SHA512 3fdb4de1a6d8f836e22d82354492b99ec9883443c389393d25ea40a08bb0b6ae03db9c947af55237b67764facd4d55a09a36cdba107c8d9202f3700fd55c31fa
diff --git a/dev-python/yapsy/yapsy-1.11.223-r2.ebuild b/dev-python/yapsy/yapsy-1.11.223-r2.ebuild
deleted file mode 100644 (file)
index 92804cb..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-MY_P="Yapsy-${PV}"
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A fat-free DIY Python plugin management toolkit"
-HOMEPAGE="http://yapsy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-python36-tests.patch
-)
-
-python_prepare_all() {
-       # Disable erroneous test
-       sed -e 's:test_default_plugins_place_is_parent_dir:_&:' \
-               -i test/test_PluginFileLocator.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       distutils-r1_python_install_all
-}