dev-python/oslo-service: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:34:12 +0000 (12:34 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:05 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-service/Manifest
dev-python/oslo-service/oslo-service-1.31.8.ebuild [deleted file]
dev-python/oslo-service/oslo-service-1.38.0.ebuild [deleted file]

index bc0be327fab48029447cff0ed4ca207d7edcfe1d..9594d9b86d93f556d93a448b97246b8da911b735 100644 (file)
@@ -1,3 +1 @@
-DIST oslo.service-1.31.8.tar.gz 72731 BLAKE2B d0460fa76df75b691dd85bed07b2bff5f8574feb84f324736769156fb1d9c74f181d8267ed69b6f8a371bd9eae3db17d5fc8588bd706da30f3cd065e8d35f80b SHA512 af4f1fc011dce56935d8ce09902172fe3c93f4907023d04c3aacb3e06631b5d5fc891ec55ee3c42acb8e29754a7519d12a38d1264935636284aee9134ce6f84f
-DIST oslo.service-1.38.0.tar.gz 78671 BLAKE2B 3291b20a60d57a251045701f890a1dc4077bec070330c4fc86e2bfaa82612e4795d0bc8b1cd8c5d8b70c7be0f45fe6db25c98b263e0a5a7bc4335bd4ae0995d9 SHA512 c2bce20abe535b12f98eea808cc95a687b226c16507ed2a4cc5f7143439f7f1a9137489ae82dc09e175165784046f6103bede3350bd6419ba5d4c134cf6aa361
 DIST oslo.service-1.40.2.tar.gz 80334 BLAKE2B 6000ba70c414ae6396f8be3911511b073f0f6a73a3a98e92e0c662b42a637b4cccbe684ceb1df2613aedad3fbd430ff588dca001997293563f39525efba05d99 SHA512 e412ae3d96e7e7f5f40238b3b9d9623a36347c3d8c6e06baa11133da71d4f5e55bd1ac2f43b45a2f84f725f84c59ec6870bc557fb623ab681bbeec27bffd086d
diff --git a/dev-python/oslo-service/oslo-service-1.31.8.ebuild b/dev-python/oslo-service/oslo-service-1.31.8.ebuild
deleted file mode 100644 (file)
index 34c9fad..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for running OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.service/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
-S="${WORKDIR}/oslo.service-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
-       >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
-       !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
-       >=dev-python/greenlet-0.4.10[${PYTHON_USEDEP}]
-       >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
-       >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
-       >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests tests/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/oslo-service/oslo-service-1.38.0.ebuild b/dev-python/oslo-service/oslo-service-1.38.0.ebuild
deleted file mode 100644 (file)
index 2f24b14..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for running OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.service/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
-S="${WORKDIR}/oslo.service-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
-       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
-       !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
-       >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-       >=dev-python/greenlet-0.4.10[${PYTHON_USEDEP}]
-       >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.40.2[${PYTHON_USEDEP}]
-       >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
-       >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
-       >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
-       >=dev-python/yappi-1.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests tests/ || die "test failed under ${EPYTHON}"
-}