dev-libs/hyphen-2.8.8: Do not install hyph_en_US.dic file
authorGino <onigino@protonmail.com>
Mon, 12 Nov 2018 07:46:12 +0000 (23:46 -0800)
committerMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 12:41:57 +0000 (14:41 +0200)
Bug: https://bugs.gentoo.org/589942

Signed-off-by: Gino McCarty <onigino@protonmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11820
[mgorny: corrected not to remove docs, fixed EAPI 7]
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/hyphen/hyphen-2.8.8-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild b/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild
new file mode 100644 (file)
index 0000000..185c29e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ALTLinux hyphenation library"
+HOMEPAGE="http://hunspell.github.io/"
+SRC_URI="mirror://sourceforge/hunspell/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-text/hunspell"
+DEPEND="${RDEPEND}
+       dev-lang/perl
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README{,.nonstandard,.hyphen,.compound} THANKS TODO )
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+
+       docinto pdf
+       dodoc doc/*.pdf
+
+       rm -r "${ED}"/usr/share/hyphen || die
+       rm "${ED}"/usr/lib*/libhyphen.la || die
+}