sci-libs/ipopt: Version bump to 3.12.12, EAPI 5 -> 6
authorGerhard Bräunlich <g.braeunlich@disroot.org>
Mon, 29 Oct 2018 10:10:48 +0000 (11:10 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 24 Apr 2019 21:13:28 +0000 (23:13 +0200)
Signed-off-by: Gerhard Bräunlich <g.braeunlich@disroot.org>
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/10293
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-libs/ipopt/Manifest
sci-libs/ipopt/ipopt-3.12.12.ebuild [new file with mode: 0644]

index 0def53e2908f1f5a1e4381452879b9cfceed3e3e..bc13ac4fb942855d5d5b7976c60ea6fd3c1abcf6 100644 (file)
@@ -1,2 +1,3 @@
 DIST Ipopt-3.11.7.tgz 4749511 BLAKE2B c344634e427a6603544e50d661cafcf6004b4192a3912453dee96cfa143ca5f290f0efc39f46e983dcba6fe5b8a0becb2fa75bd6cc6f27be5c8ea8dc05f1ec4c SHA512 a9edd33b59c9744dc4e09d709519be1fc3d014cc4f50254402784aa8035d21617323f2879c430245886f2a13165cc81d26779331dc1601f0edfc406953dca56f
 DIST Ipopt-3.11.8.tgz 4749758 BLAKE2B c5ee5d3f01f1e8b4b6a1cd7606e2ad1a24c09fb0a8d8ed93fda7af61d543ac4f4579d7bb8817607d916223d9214693e1156f908cef1233a75df8759a1099b5d2 SHA512 1f60ea769dd7305348af3a5d4ed56938f04e59c36fb7a3fa0b808e4788dccee4711f82c3767e2aae87d21618d2a840d0bb22491c21c40bc2f9ebdf4b3a01aeec
+DIST Ipopt-3.12.12.tgz 4530034 BLAKE2B 8a8e24e4e5d8ad5bc1fcfa2de525e1e39c88a4c6dd77b51c0549249f517b3d6a1279e355a7cb606ebd8e606551031b653b78cd4d1cb51dd369e051ffa010011f SHA512 c543695feaa39a69b01e0025ebcd8a8772deb369ea1072f17da4ba34c1b522d322959067f3a6cfc40446e00c2e6dd2d6704a55623aba5d61dff44333727368cb
diff --git a/sci-libs/ipopt/ipopt-3.12.12.ebuild b/sci-libs/ipopt/ipopt-3.12.12.ebuild
new file mode 100644 (file)
index 0000000..7aba7e6
--- /dev/null
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_NEEDED="mumps"
+
+inherit autotools fortran-2 toolchain-funcs
+
+MY_PN=${PN^}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Interior-Point Optimizer for large-scale nonlinear optimization"
+HOMEPAGE="https://projects.coin-or.org/Ipopt/"
+SRC_URI="http://www.coin-or.org/download/source/${MY_PN}/${MY_P}.tgz"
+
+LICENSE="EPL-1.0 hsl? ( HSL )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hsl lapack mpi mumps static-libs test"
+RESTRICT="test" # Fails to compile
+
+RDEPEND="
+       virtual/blas
+       hsl? ( sci-libs/coinhsl:0= )
+       lapack? ( virtual/lapack )
+       mpi? ( virtual/mpi )
+       mumps? ( sci-libs/mumps:0=[mpi=] )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen[dot] )
+       test? ( sci-libs/coinor-sample sci-libs/mumps )"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${MY_PN}"
+
+src_prepare() {
+       if use mpi ; then
+               export CXX=mpicxx FC=mpif77 F77=mpif77 CC=mpicc
+       fi
+       default
+}
+
+src_configure() {
+       # needed for --with-coin-instdir
+       dodir /usr
+       local myeconfargs=(
+               --enable-dependency-linking
+               --with-blas-lib="$($(tc-getPKG_CONFIG) --libs blas)"
+               --with-coin-instdir="${ED%/}"/usr
+               $(use_with doc dot)
+       )
+
+       if use lapack; then
+               myeconfargs+=( --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" )
+       else
+               myeconfargs+=( --without-lapack )
+       fi
+       if use mumps; then
+               myeconfargs+=(
+                       --with-mumps-incdir="${EPREFIX}"/usr/include$(usex mpi '' '/mpiseq')
+                       --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps" )
+       else
+               myeconfargs+=( --without-mumps )
+       fi
+       if use hsl; then
+               myeconfargs+=(
+                       --with-hsl-incdir="${EPREFIX}"/usr/include
+                       --with-hsl-lib="$($(tc-getPKG_CONFIG) --libs coinhsl)" )
+       else
+               myeconfargs+=( --without-hsl )
+       fi
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       emake all
+       use doc && emake doxydoc
+}
+
+src_test() {
+       emake test
+}
+
+src_install() {
+       default
+       local HTML_DOCS DOCS
+       use doc && HTML_DOCS=("${S}/doxydoc/html/.")
+       use examples && DOCS+=( examples )
+       einstalldocs
+
+       rm -r "${ED%/}"/usr/share/coin || die
+}