dev-python/tablib: RESTRICT tests
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 24 Aug 2018 13:04:53 +0000 (09:04 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 24 Aug 2018 13:04:53 +0000 (09:04 -0400)
To be able to fast-stabilize due to security bug, we need to RESTRICT
tests because they depend on pandas>=0.23 which is hard to stabilize.

Bug: https://bugs.gentoo.org/659790
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-python/tablib/tablib-0.12.1-r1.ebuild

index d720bb4e446e529f56126c399fa7bd5ff29f6493..8f70686e3f7d7ea4542ee23faafa38399680bba9 100644 (file)
@@ -24,17 +24,19 @@ RDEPEND="
        dev-python/xlwt[${PYTHON_USEDEP}]
 "
 
-# Presence of pandas older than v0.23 makes tablib tests (which sometimes tries
-# to load pandas dataframes) fail.
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]
-               !<dev-python/pandas-0.23
        )
 "
 
+# Test require >=dev-python/pandas-0.23 which is difficult to stabilize. At the
+# time of this writing, we had to stabilize tablib due to a security bug, which
+# is why we temporarily RESTRICT tests. Bug #659790
+RESTRICT="test"
+
 PATCHES=(
        # https://github.com/kennethreitz/tablib/issues/297
        "${FILESDIR}/${PN}-0.12.1-no-ujson.patch"