Getting rid of gtk1 support (bug #106560)
authorPatrick Kursawe <phosphan@gentoo.org>
Tue, 20 Sep 2005 16:27:31 +0000 (16:27 +0000)
committerPatrick Kursawe <phosphan@gentoo.org>
Tue, 20 Sep 2005 16:27:31 +0000 (16:27 +0000)
Package-Manager: portage-2.0.51.22-r2

sci-chemistry/chemtool/ChangeLog
sci-chemistry/chemtool/Manifest
sci-chemistry/chemtool/chemtool-1.6.7-r1.ebuild [new file with mode: 0644]
sci-chemistry/chemtool/files/digest-chemtool-1.6.7-r1 [new file with mode: 0644]

index 3093b6857e493a23b681c9713e5a540d853534be..c45076d1924a1230a117b62b9eb0f521d741d7de 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sci-chemistry/chemtool
 # Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.7 2005/09/16 09:45:43 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.8 2005/09/20 16:27:31 phosphan Exp $
+
+*chemtool-1.6.7-r1 (20 Sep 2005)
+
+  20 Sep 2005; Patrick Kursawe <phosphan@gentoo.org>
+  +chemtool-1.6.7-r1.ebuild:
+  Getting rid of gtk1 support (bug #106560)
 
   16 Sep 2005; Patrick Kursawe <phosphan@gentoo.org> chemtool-1.6.6.ebuild,
   chemtool-1.6.7.ebuild:
index 57a96c530aad158d2c12dee70aeb199355852c6c..2f15c20ff2f43e881aeb04430689cd5338e7cb6f 100644 (file)
@@ -1,9 +1,11 @@
 MD5 372559212ea87a5bd27a53e6a03fa8ea chemtool-1.6.3.ebuild 1951
 MD5 7d10c746ffc8cb3e6c1b3b1ce883f52c chemtool-1.6.7.ebuild 1962
 MD5 9e2101d05a406781b0e7edbd09b89e15 chemtool-1.6.4.ebuild 2073
+MD5 213e05816c747a5717ff86f064785bf3 chemtool-1.6.7-r1.ebuild 1842
 MD5 fbbb209c3e2234f852270a8bad2a38bc chemtool-1.6.6.ebuild 1961
-MD5 4d73c5a706d910245432ef277ba5c114 ChangeLog 3476
+MD5 8f3703f21924d2ab1ea58ea057e9cca6 ChangeLog 3637
 MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 27dfa5500bf82b518c1ea34ae01c73ee files/digest-chemtool-1.6.7-r1 66
 MD5 4ae73ea952733fc1500a98a82b1b8f3d files/digest-chemtool-1.6.3 66
 MD5 73e6d16f503d84f586445148c62e1a32 files/digest-chemtool-1.6.4 66
 MD5 5f0baeb289dacc7ef250d44bf8e2fd16 files/digest-chemtool-1.6.6 66
diff --git a/sci-chemistry/chemtool/chemtool-1.6.7-r1.ebuild b/sci-chemistry/chemtool/chemtool-1.6.7-r1.ebuild
new file mode 100644 (file)
index 0000000..dbd2ee3
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.7-r1.ebuild,v 1.1 2005/09/20 16:27:31 phosphan Exp $
+
+inherit eutils kde-functions
+
+DESCRIPTION="program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="gnome kde nls"
+
+DEPEND=">=media-gfx/transfig-3.2.3d
+               =x11-libs/gtk+-2* 
+               kde? ( kde-base/kdelibs )
+               x86? ( >=media-libs/libemf-1.0 )"
+
+src_compile() {
+       local config_opts
+       local mycppflags
+       if ! use kde; then
+               unset KDEDIR
+               config_opts="${config_opts} --without-kdedir"
+       else
+               set-kdedir
+               config_opts="${config_opts} --with-kdedir=${KDEDIR}"
+       fi
+       if [ ${ARCH} = "x86"  ]; then
+               config_opts="${config_opts} --enable-emf"
+               mycppflags="${mycppflags} -I /usr/include/libEMF"
+       fi
+
+       sed -e "s:\(^CPPFLAGS.*\):\1 ${mycppflags}:" -i Makefile.in || \
+               die "could not append cppflags"
+
+       if use gnome ; then
+               config_opts="${config_opts} --with-gnomedir=/usr" ;
+       else
+               config_opts="${config_opts} --without-gnomedir" ;
+       fi
+
+       econf ${config_opts} \
+               || die "./configure failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       local sharedirs="applnk/Graphics mimelnk/application icons/hicolor/32x32/mimetypes"
+       for dir in ${sharedirs}; do
+               dodir ${mykdedir}/share/${dir}
+       done
+       dodir /usr/share/mime-types
+       dodir /usr/share/pixmaps/mc
+
+       make DESTDIR="${D}" install || die "make install failed"
+
+       if ! use gnome; then
+               rm -rf ${D}/usr/share/pixmaps ${D}/usr/share/mime-types
+       fi
+
+       dodoc ChangeLog INSTALL README TODO
+       insinto /usr/share/${PN}/examples
+       doins ${S}/examples/*
+       if ! use nls; then rm -rf ${D}/usr/share/locale; fi
+}
diff --git a/sci-chemistry/chemtool/files/digest-chemtool-1.6.7-r1 b/sci-chemistry/chemtool/files/digest-chemtool-1.6.7-r1
new file mode 100644 (file)
index 0000000..c6497a9
--- /dev/null
@@ -0,0 +1 @@
+MD5 663cd50e7f2bc6b687454ef9c47b7a50 chemtool-1.6.7.tar.gz 427878