dev-util/vint: mark stable``
authorMikle Kolyada <zlogene@gentoo.org>
Thu, 7 May 2020 22:01:30 +0000 (01:01 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Thu, 7 May 2020 22:01:30 +0000 (01:01 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-util/vint/Manifest
dev-util/vint/vint-0.3.18.ebuild [deleted file]
dev-util/vint/vint-0.3.19.ebuild [deleted file]
dev-util/vint/vint-0.3.21.ebuild

index b146fad7a21d363c047e294e37d00b9ece71281c..816b3a753214e4af934d56e7a1ef7f16a698ecd9 100644 (file)
@@ -1,3 +1 @@
-DIST vint-0.3.18.tar.gz 95865 BLAKE2B 0f7e61b720aa0998091b9b40118b199392fbf1aeace8801d683e8249179cd3d792e15b42df6d34c567c4df1830629a80e6043e87092f37dc46a0e57c6a56cf53 SHA512 1d3e04527a8f5ffae29395010a88258c1771aff2798143eff6572400eaf96323cad04353a7fcee68d9407afde5808446f515fd3d7e8e62de4bef28edf214ebdd
-DIST vint-0.3.19.tar.gz 96755 BLAKE2B 0b03807a4286b3e030e00c112dd0e879fa39e0d2333d46ea159555de50b30098d9a8b2345da8e18b7e1e5c814f10678df2e64398a615bf381186faa0036939f5 SHA512 b9024ed1cd8a18a916798e691ba0db31985034b2420e33c094459a48254c7c8f6fe89a1a64858a67ff95b0b48e67a780cf975940646af2685d2b95640e8121f9
 DIST vint-0.3.21.tar.gz 96747 BLAKE2B 926b46493030dc0daa477ded3cb70f2b825b4eb8054c14a4b824b97e7df60d0141cf1bcf4c33893afd870f51308b7156fb6e5870f320f8c9449fdca8fe78774f SHA512 47e832d382952cb16bcc233eefa1f06ca74f95eb445d7f96d6804391b91a2c8a8e7b749b7f33f65aed9d3bdc1ff5e5332a62c3935969395f16a854f0f66e383b
diff --git a/dev-util/vint/vint-0.3.18.ebuild b/dev-util/vint/vint-0.3.18.ebuild
deleted file mode 100644 (file)
index 6039b45..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Lint tool for Vim script language"
-HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.org/project/vim-vint/"
-SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
-       >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? (
-               >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
-               >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
-               >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-
-       # Don't try to use an installed vint executable.
-       # See https://github.com/Kuniwak/vint/issues/22
-       sed -i -e "s|'vint'|'bin/vint'|" test/acceptance/test_cli{,_vital}.py || die
-}
-
-python_test() {
-       py.test -v || die "Test suite failed with ${EPYTHON}"
-}
diff --git a/dev-util/vint/vint-0.3.19.ebuild b/dev-util/vint/vint-0.3.19.ebuild
deleted file mode 100644 (file)
index 79f99c6..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Lint tool for Vim script language"
-HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.org/project/vim-vint/"
-SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
-       >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? (
-               >=dev-python/pytest-3.3.2[${PYTHON_USEDEP}]
-       )
-"
-
-python_test() {
-       pytest -vv || die "Test suite failed with ${EPYTHON}"
-}
index 6f3784ee9362fb9ce798d1d50525a0adb86fb193..00521d56eba744c2904f94e2a6edf5f4738bc8d9 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
 
 RDEPEND="
        >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]