app-office/libreoffice: Set IUSE="+dbus", gtk requires sys-apps/dbus[X]
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 22 May 2020 12:36:51 +0000 (14:36 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 22 May 2020 14:09:28 +0000 (16:09 +0200)
Try to fix 'minimalist WM' corner case.

Closes: https://bugs.gentoo.org/716712
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/libreoffice/libreoffice-6.4.9999.ebuild
app-office/libreoffice/libreoffice-9999.ebuild

index 96cb016126398feeb7e3902e84f5313b40d5b123..e42e510981a9f4369f8915934eef90a5be6e1fd2 100644 (file)
@@ -64,12 +64,13 @@ unset ADDONS_SRC
 # Extensions that need extra work:
 LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
 
-IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+IUSE="accessibility bluetooth +branding coinmp +cups +dbus debug eds firebird
 googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test
 $(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
        bluetooth? ( dbus )
+       gtk? ( dbus )
        libreoffice_extensions_nlpsolver? ( java )
        libreoffice_extensions_scripting-beanshell? ( java )
        libreoffice_extensions_scripting-javascript? ( java )
@@ -164,7 +165,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        )
        coinmp? ( sci-libs/coinor-mp )
        cups? ( net-print/cups )
-       dbus? ( sys-apps/dbus )
+       dbus? ( sys-apps/dbus[X] )
        eds? (
                dev-libs/glib:2
                gnome-base/dconf
index 536c445e0306ad1bfb895624e0cdb2e414aa1bb2..3e5059a2035665f4fbf98f47cddbc2c733c355d8 100644 (file)
@@ -68,12 +68,13 @@ unset ADDONS_SRC
 # Extensions that need extra work:
 LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
 
-IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+IUSE="accessibility bluetooth +branding coinmp +cups +dbus debug eds firebird
 googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test
 $(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}
        bluetooth? ( dbus )
+       gtk? ( dbus )
        libreoffice_extensions_nlpsolver? ( java )
        libreoffice_extensions_scripting-beanshell? ( java )
        libreoffice_extensions_scripting-javascript? ( java )
@@ -168,7 +169,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        )
        coinmp? ( sci-libs/coinor-mp )
        cups? ( net-print/cups )
-       dbus? ( sys-apps/dbus )
+       dbus? ( sys-apps/dbus[X] )
        eds? (
                dev-libs/glib:2
                gnome-base/dconf