net-mail/dovecot: [QA] Fix UnnecessarySlashStrip
authorDavid Seifert <soap@gentoo.org>
Sat, 8 Feb 2020 16:23:05 +0000 (17:23 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 8 Feb 2020 16:23:05 +0000 (17:23 +0100)
Signed-off-by: David Seifert <soap@gentoo.org>
net-mail/dovecot/dovecot-2.3.8.ebuild
net-mail/dovecot/dovecot-2.3.9.2.ebuild

index b32f3cabf59d1f1b0dec956892d1bd00210440ef..8260f001111606f76b23d8ec2ffea8bf32aa2e5d 100644 (file)
@@ -91,9 +91,9 @@ src_configure() {
 
        # turn valgrind tests off. Bug #340791
        VALGRIND=no econf \
-               --with-rundir="${EPREFIX%/}/run/dovecot" \
-               --with-statedir="${EPREFIX%/}/var/lib/dovecot" \
-               --with-moduledir="${EPREFIX%/}/usr/$(get_libdir)/dovecot" \
+               --with-rundir="${EPREFIX}/run/dovecot" \
+               --with-statedir="${EPREFIX}/var/lib/dovecot" \
+               --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
                --without-stemmer \
                --disable-rpath \
                --without-libbsd \
@@ -128,7 +128,7 @@ src_configure() {
                cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
                econf \
                        $( use_enable static-libs static ) \
-                       --localstatedir="${EPREFIX%/}/var" \
+                       --localstatedir="${EPREFIX}/var" \
                        --enable-shared \
                        --with-dovecot="${S}" \
                        $( use_with managesieve )
index 6a614a62c190c7190d68d2ac4378a8fc1ec3ce47..f2ee9cd425ca123290ecb9b9fb488b4503a706f5 100644 (file)
@@ -91,9 +91,9 @@ src_configure() {
 
        # turn valgrind tests off. Bug #340791
        VALGRIND=no econf \
-               --with-rundir="${EPREFIX%/}/run/dovecot" \
-               --with-statedir="${EPREFIX%/}/var/lib/dovecot" \
-               --with-moduledir="${EPREFIX%/}/usr/$(get_libdir)/dovecot" \
+               --with-rundir="${EPREFIX}/run/dovecot" \
+               --with-statedir="${EPREFIX}/var/lib/dovecot" \
+               --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
                --without-stemmer \
                --disable-rpath \
                --without-libbsd \
@@ -128,7 +128,7 @@ src_configure() {
                cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
                econf \
                        $( use_enable static-libs static ) \
-                       --localstatedir="${EPREFIX%/}/var" \
+                       --localstatedir="${EPREFIX}/var" \
                        --enable-shared \
                        --with-dovecot="${S}" \
                        $( use_with managesieve )