dev-ml/biniou: bump to 1.0.12; update homepage & src_uri
authorAlexis Ballier <aballier@gentoo.org>
Mon, 11 Jul 2016 10:26:55 +0000 (12:26 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 11 Jul 2016 10:30:14 +0000 (12:30 +0200)
Package-Manager: portage-2.3.0

dev-ml/biniou/Manifest
dev-ml/biniou/biniou-1.0.12.ebuild [new file with mode: 0644]

index 31c44be21c1e494a2b12945649db67c202e9aec5..a5ee8f49b4b76009ee5f3be94f5bdcdfcf91a89c 100644 (file)
@@ -1 +1,2 @@
+DIST biniou-1.0.12.tar.gz 24262 SHA256 b946e720d94d524b95bb0401d9e47a971e9234df808fe5f12601140ab09ec686 SHA512 df729e4064f6726efa409ceb5e6ff1987923d9cd28339d6e1c4c185a07c0738b027cafba33a139483eeb8f88e58f66fbb6a57d8e748e7355073a7622fb4d7a07 WHIRLPOOL ae337546d7737a733cedc78fd515bf55603edf9b49be3587ca97d45887ecaac82d072aa8391c72b8142aaadbe7b7d1e4394da1c28ee3d16eb8985c85d665f8fd
 DIST biniou-1.0.9.tar.gz 23963 SHA256 eb47c48f61b169e652629e7f2ee582dfd5965e640ee51bf28fab63b960864392 SHA512 8bc640da28ad8f95952b7a0965f8b40c6128264fb4cd5b517cba2e65b432803a01dc75e42d9d339376dbb962285c7e4ad8290f2536f58d092fe7269b731fb332 WHIRLPOOL aa7cf2486886cd26513028065d654f7c1b768e4950f568147758d5fa61cb6fcdc11a2f3da5ed6b60b8eadee14e3b8885e5197d52e01c8a61b284712cea7e9aa9
diff --git a/dev-ml/biniou/biniou-1.0.12.ebuild b/dev-ml/biniou/biniou-1.0.12.ebuild
new file mode 100644 (file)
index 0000000..8f403bb
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+       dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+       emake all
+       use ocamlopt && emake opt
+}
+
+src_install() {
+       use ocamlopt && dodir /usr/bin
+       findlib_src_install BINDIR="${ED}"/usr/bin
+       dodoc README.md Changes
+}