net-analyzer/nagios-core: new revision to fix CGI install path.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 19 Jan 2019 20:40:07 +0000 (15:40 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 19 Jan 2019 21:06:18 +0000 (16:06 -0500)
Upstream commit 37da6f39c8 fixes an old bug in the build system, where
CGIDIR was set to @sbindir@ (rather than to @cgibindir@), and HTMLDIR
was set to @datarootdir@ (rather than to @webdir@). Now that the bug
is fixed, the ebuild has been revisioned to use the right configure flags:
we pass --with-cgibindir the old argument of --sbindir, and --with-webdir
the old argument of --datadir.

Thanks to Tomáš Mózes for the report and the fix.

Closes: https://bugs.gentoo.org/675872
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-analyzer/nagios-core/nagios-core-4.4.3-r1.ebuild [moved from net-analyzer/nagios-core/nagios-core-4.4.3.ebuild with 97% similarity]

similarity index 97%
rename from net-analyzer/nagios-core/nagios-core-4.4.3.ebuild
rename to net-analyzer/nagios-core/nagios-core-4.4.3-r1.ebuild
index d568d350d5867f484ca6c59f1a9fc1fedbb8e7ef..74ddb853c43eb791bf0e70e4fd495bdace5cf058 100644 (file)
@@ -96,11 +96,11 @@ src_configure() {
        econf ${myconf} \
                --prefix=/usr \
                --bindir=/usr/sbin \
-               --sbindir=/usr/$(get_libdir)/nagios/cgi-bin \
-               --datadir=/usr/share/nagios/htdocs \
                --localstatedir=/var/nagios \
                --sysconfdir=/etc/nagios \
-               --libexecdir=/usr/$(get_libdir)/nagios/plugins
+               --libexecdir=/usr/$(get_libdir)/nagios/plugins \
+               --with-cgibindir=/usr/$(get_libdir)/nagios/cgi-bin \
+               --with-webdir=/usr/share/nagios/htdocs
 }
 
 src_compile() {