dev-python/readthedocs-sphinx-ext: Bump to 1.0.4
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:51:26 +0000 (08:51 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:03:17 +0000 (09:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/readthedocs-sphinx-ext/Manifest
dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.4.ebuild [new file with mode: 0644]

index a8250eca244b60438a05296926058edf2c829cb3..3aef4c5fdc0959ee699c85f33ec022c1c6b7530f 100644 (file)
@@ -1 +1,2 @@
 DIST readthedocs-sphinx-ext-1.0.3.tar.gz 11589 BLAKE2B 9c6ac1bd3baa2a92cbc67d18f5fd6b3f63ce0fe7cc16832ad23940c7b8d85d88f299c8cba6623d0c2b229cbcc43e43ece926aefa01d6a3055ef9c252ddf68dfd SHA512 571336adbb3f6c9077d2530562f5d72092f8df440b282187fca5aaeb2a9c281aa49bc29423e550905696a200f692ebcea5fe6f83e023f64759224697c49e2f03
+DIST readthedocs-sphinx-ext-1.0.4.tar.gz 11686 BLAKE2B 3c188e52682f8c24633f79b9ec0eed7f06c922989f7578f06e0ede0e3844ca019e1905450df8d12150d05f3a82a1103a0786cb2c60dc3551e3e3097849cdc301 SHA512 52f45c26ae934b44a41073a9e77096ea8ed97f2a36ed1ea9b63084be0af58dcff24c6b729cda7a8b631f9fe5f56822ceabdbbd2e11056b44df18212986cb445a
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.4.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.4.ebuild
new file mode 100644 (file)
index 0000000..e8bb844
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+       >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]"
+PDEPEND="
+       dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( ${PDEPEND} )"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest