dev-python/pyx: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:14:42 +0000 (22:14 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:24:50 +0000 (22:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyx/Manifest
dev-python/pyx/pyx-0.14.1-r1.ebuild [deleted file]
dev-python/pyx/pyx-0.14.1.ebuild [deleted file]

index aa62effd2c5c4c2ad14e6ea5424be12ba0965427..7103b8d91882ceaf3dba4618f696f6b0e4794927 100644 (file)
@@ -1,3 +1,2 @@
-DIST PyX-0.14.1.tar.gz 2475186 BLAKE2B 5e18b2a052c586cfdcfcc46f5351683ce7c3ec41d508b6fd5e085be543ac3730ee866b636d3ab9663e782b95efafcc340260826c82a77955b586ad7a55676c5b SHA512 16265bbdcaf28ce194189a2987b32952f296c850b829454bcccce0abd23838bfca0276c3e9c8e96b8cbfaf1473bf14669f9b7f2032ee039b61ae59ea3aa45a20
 DIST W3C_SVG_11_TestSuite.tar.gz 14651624 BLAKE2B 680059d8b20775725cebb3aed4444acbc3222fde880ba93ee5186c99fc12afa8df2c790bdacbcd6e5ff4ab00e697d8317a9a6ae3039b8b2f02cf7774a18ca533 SHA512 e28e3996284c3f3e423e2b6957cddea71980bcb781d4180894e08f37a7ecce9c6021917329d6d433dcba792cbabb15c7cd503076e616ba5189193a5c554374ca
 DIST pyx-0.15.gh.tar.gz 875286 BLAKE2B 49d36e1c0df3ee47a895279d7f296194324cf1582bb7db0259bcd01c9b17c4d0903c25fef10c7a22635fac62dc6378ffbece200eac99f75bb3ce81d48a71a0d1 SHA512 a7debff01f8055455855f4cac5a08d00c22d20d7918bd7341d2af83844223ae8bb23bbbe92149403656e18ffb8861e8568dfdcb59cc01c55ec60e63b62a8825a
diff --git a/dev-python/pyx/pyx-0.14.1-r1.ebuild b/dev-python/pyx/pyx-0.14.1-r1.ebuild
deleted file mode 100644 (file)
index 529d32e..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-MY_PN=PyX
-MY_P="${P/pyx/PyX}"
-DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
-HOMEPAGE="https://pyx.sourceforge.net/
-       https://pypi.org/project/PyX/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="virtual/tex-base
-               dev-texlive/texlive-basic"
-
-DEPEND="${RDEPEND}
-       doc? ( virtual/latex-base
-               dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${P}-unicode-latex.patch )
-
-src_prepare() {
-       distutils-r1_src_prepare
-       sed -i \
-               -e 's/^build_t1code=.*/build_t1code=1/' \
-               -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
-               setup.cfg || die "setup.cfg fix failed"
-}
-
-python_compile_all() {
-       if use doc; then
-               VARTEXFONTS="${T}"/fonts
-               emake -C "${S}"/manual latexpdf
-               emake -C "${S}"/faq latexpdf
-       fi
-}
-
-python_install_all() {
-       use doc && dodoc manual/_build/latex/manual.pdf faq/_build/latex/pyxfaq.pdf
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/pyx/pyx-0.14.1.ebuild b/dev-python/pyx/pyx-0.14.1.ebuild
deleted file mode 100644 (file)
index b9e6d91..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-MY_PN=PyX
-MY_P="${P/pyx/PyX}"
-DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
-HOMEPAGE="https://pyx.sourceforge.net/
-       https://pypi.org/project/PyX/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="virtual/tex-base
-               dev-texlive/texlive-basic"
-
-DEPEND="${RDEPEND}
-       doc? ( virtual/latex-base
-               dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-       distutils-r1_src_prepare
-       sed -i \
-               -e 's/^build_t1code=.*/build_t1code=1/' \
-               -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
-               setup.cfg || die "setup.cfg fix failed"
-}
-
-python_compile_all() {
-       if use doc; then
-               VARTEXFONTS="${T}"/fonts
-               emake -C "${S}"/manual latexpdf
-               emake -C "${S}"/faq latexpdf
-       fi
-}
-
-python_install_all() {
-       use doc && dodoc manual/_build/latex/manual.pdf faq/_build/latex/pyxfaq.pdf
-       distutils-r1_python_install_all
-}