seems like the code is fragile (bug #559548) so drop down to very conservative CFLAGS
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Sep 2015 18:04:25 +0000 (14:04 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Sep 2015 18:04:37 +0000 (14:04 -0400)
Package-Manager: portage-2.2.20.1

games-rpg/freedink/freedink-108.4.ebuild

index 8d47573110d9d7d46bd889e888ccde0fcbd9c8e3..dafba425737d169c4cd195d6e658ccd6bed94289 100644 (file)
@@ -3,7 +3,7 @@
 # $Id$
 
 EAPI=5
-inherit games
+inherit flag-o-matic games
 
 DESCRIPTION="Dink Smallwood is an adventure/role-playing game, similar to Zelda (2D top view)"
 HOMEPAGE="http://www.freedink.org/"
@@ -32,6 +32,9 @@ src_prepare() {
        sed -i \
                -e 's#^datarootdir =.*$#datarootdir = /usr/share#' \
                share/Makefile.in || die
+       # seems like the code is fragile (bug #559548)
+       filter-flags
+       replace-flags -O? -O0
 }
 
 src_configure() {