dev-ruby/rbst: New package
authorMichał Górny <mgorny@gentoo.org>
Mon, 9 Oct 2017 19:41:02 +0000 (21:41 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 9 Oct 2017 19:43:06 +0000 (21:43 +0200)
dev-ruby/rbst/Manifest [new file with mode: 0644]
dev-ruby/rbst/metadata.xml [new file with mode: 0644]
dev-ruby/rbst/rbst-0.5.1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/rbst/Manifest b/dev-ruby/rbst/Manifest
new file mode 100644 (file)
index 0000000..1f6e7cf
--- /dev/null
@@ -0,0 +1 @@
+DIST rbst-0.5.1.tar.gz 14039 SHA256 95d8ba25bde6c16e0565f480b377c9377168af889c32a90b0a55dd46cf74f547 SHA512 a7fffc1ccf495c1858d6d9fadd38a4d6a2c27a2da8eda8dad038f4ab881f4521223a35f97d4018d25b32c2621132a623040ba930494b36e1385356ecb87fecdc WHIRLPOOL d31d1742f9e998388da6d0f763ed558596b5a84cc1ae66ae296d45a26add0fefefb92b571d32cede481d28a2a3ac8eabf91cd1dc9bcc907d20bf9b9b604bd994
diff --git a/dev-ruby/rbst/metadata.xml b/dev-ruby/rbst/metadata.xml
new file mode 100644 (file)
index 0000000..0319eec
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mgorny@gentoo.org</email>
+               <name>Michał Górny</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rbst/rbst-0.5.1.ebuild b/dev-ruby/rbst/rbst-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..47d5cfc
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_NAME="RbST"
+RUBY_FAKEGEM_GEMSPEC="RbST.gemspec"
+
+inherit python-single-r1 ruby-fakegem
+
+DESCRIPTION="A simple Ruby wrapper for processing rST via docutils"
+HOMEPAGE="https://github.com/alphabetum/rbst"
+SRC_URI="https://github.com/alphabetum/rbst/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/docutils"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               >=dev-ruby/mocha-1.1.0:1.0
+               >=dev-ruby/shoulda-3.5.0:3
+               >=dev-ruby/test-unit-3.0.9:2
+       )"
+
+# Tests are pretty much useless as they depend on very specific output
+# from an unknown docutils version.
+RESTRICT="test"
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+       ruby-ng_pkg_setup
+}
+
+all_ruby_prepare() {
+       # do not use bundler
+       sed -i -e '/bundler/,/end/d' \
+               Rakefile test/helper.rb || die
+
+       # force our python version
+       sed -i -e "s:\(python_path=\"\)python:\1${EPYTHON}:" lib/rbst.rb || die
+       python_fix_shebang lib/rst2parts
+}