dev-util/waf: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 15:15:44 +0000 (16:15 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 16:53:00 +0000 (17:53 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-util/waf/Manifest
dev-util/waf/waf-1.9.8.ebuild [deleted file]

index fc7aa9e3a2a92b286546d866babee77cf15af2cb..4648e34df5dfe9e1d91ec7834659f523c704d91b 100644 (file)
@@ -1,2 +1 @@
 DIST waf-1.9.14.tar.bz2 631021 BLAKE2B b822cfcee033846b075baad98c69833d54563a23075704acdf6c140b08cf4c5e263465b618830ecae979eaf741f83a849f37d714c18cf355b49a62bc30214904 SHA512 5b7e556eeb3ceec83e81e9b849786d7921aa06e443aa2fb5f288e3fcef6b05b3a1a6aa4ebcdfd0bd345ea3166980cb926cbea2260a229613bdcb2def86fb5816
-DIST waf-1.9.8.tar.bz2 620795 BLAKE2B d7c3ad5cf0c1b16aef84b311d7fe2d26e7e6fe0438373e19387cade0356469100063059e6900398c7bb4993d9440f79933ba59d1bdd1b71e41364d1659b18d55 SHA512 a86d29d32257ee5b82db28f20ef3056a995c4a47404ee47f216899c76332c6586bde83397db907b51c8d3d38efaa3e2f4befbf8f27d17d1f58e6b0808f070fdc
diff --git a/dev-util/waf/waf-1.9.8.ebuild b/dev-util/waf/waf-1.9.8.ebuild
deleted file mode 100644 (file)
index e37a342..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-PYTHON_REQ_USE="threads(+)"
-inherit python-any-r1 toolchain-funcs
-
-DESCRIPTION="piece of software used to help building software projects"
-HOMEPAGE="https://waf.io/"
-SRC_URI="https://waf.io/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-DEPEND="${PYTHON_DEPS}"
-
-DOCS="ChangeLog README.md DEVEL"
-
-src_prepare() {
-       rm -v waf || die
-
-       default
-}
-
-src_configure() {
-       ${EPYTHON} ./waf-light configure
-}
-
-src_compile() {
-       ${EPYTHON} ./waf-light build
-}
-
-src_install() {
-       default
-
-       #point waf binary to waflib dir and strip payload
-       sed -e "/INSTALL=/s:=.*:='${EROOT}usr':" \
-               -e "/REVISION=/s:=.*:='${PR}':" \
-               -e "s:/lib/:/$(get_libdir)/:" \
-               -e "/^#\(==>\|BZ\|<==\)/d" \
-               -i waf || die
-       dobin waf
-
-       insinto /usr/$(get_libdir)/${PN}3-${PV}-${PR}
-       doins -r waflib
-
-       if use examples ; then
-               dodoc -r demos
-       fi
-}