Eliminate redundant "notadded" error filtering.
authorZac Medico <zmedico@gentoo.org>
Fri, 21 Dec 2007 03:28:48 +0000 (03:28 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 21 Dec 2007 03:28:48 +0000 (03:28 -0000)
svn path=/main/trunk/; revision=9023

bin/repoman

index 68a692d57c1e7b0f756e0d130567dbb7b9d5ec6c..e7b8412826ed2eadba625c55deb1701d29694a41 100755 (executable)
@@ -477,9 +477,6 @@ def last(full=False):
        for x in qacats:
                if not stats[x]:
                        continue
-               if "notadded" in x and not isCvs:
-                       stats[x] = 0
-                       continue
                dowarn = 1
                if x not in qawarnings:
                        dofail = 1
@@ -1214,7 +1211,7 @@ for x in scanlist:
                if os.stat(checkdir+"/"+y+".ebuild")[0] & 0x0248:
                        stats["file.executable"] += 1
                        fails["file.executable"].append(x+"/"+y+".ebuild")
-               if y not in eadded:
+               if isCvs and y not in eadded:
                        #ebuild not added to cvs
                        stats["ebuild.notadded"]=stats["ebuild.notadded"]+1
                        fails["ebuild.notadded"].append(x+"/"+y+".ebuild")
@@ -1645,9 +1642,6 @@ dofull = options.mode not in ("full", "lfull")
 for x in qacats:
        if not stats[x]:
                continue
-       if "notadded" in x and not isCvs:
-               stats[x] = 0
-               continue
        dowarn = 1
        if x not in qawarnings:
                dofail = 1