app-editors/hteditor: use ${CHOST}-ar, not ar, gug #722040
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 10 May 2020 09:27:03 +0000 (10:27 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 10 May 2020 09:27:12 +0000 (10:27 +0100)
AC_PATH_PROG needs absolute path and does not add ${CHOST}
prefix. AC_CHECK_TOOL does the opposite. Use that.

Reported-by: Agostino Sarubbo
Closes: https://bugs.gentoo.org/722040
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-editors/hteditor/files/hteditor-2.1.0-AR.patch [new file with mode: 0644]
app-editors/hteditor/hteditor-2.1.0-r1.ebuild

diff --git a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch b/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
new file mode 100644 (file)
index 0000000..60a0427
--- /dev/null
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/722040
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,8 +104,8 @@ AC_PROG_CPP
+ AC_PROG_CXX
+ AC_PROG_YACC
+ AM_PROG_LEX
+-AC_PATH_PROG(AR, ar)
+-AC_PATH_PROG(AR, gar)
++AC_CHECK_TOOL(AR, ar)
++AC_CHECK_TOOL(AR, gar)
+ if test "x$AR" = "x"; then
+          AC_MSG_ERROR([*** 'ar' and 'gar' missing, please install one of them or fix your \$PATH ***])
index 44b7dd140f67b3a04546aba324f0011658dc34ee..d8a7a241a3d4487e6b84dcb0cdd3e4697d3150bf 100644 (file)
@@ -33,6 +33,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-gcc-6-uchar.patch
        "${FILESDIR}"/${P}-format-security.patch
        "${FILESDIR}"/${P}-gcc-10.patch
+       "${FILESDIR}"/${P}-AR.patch
 )
 
 src_prepare() {
@@ -46,9 +47,9 @@ src_configure() {
                --enable-maintainermode
 }
 
-src_compile() {
-       emake AR="$(tc-getAR)" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-}
+#src_compile() {
+#      emake AR="$(tc-getAR)" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+#}
 
 src_install() {
        #For prefix