app-emulation/containerd: Temporarily change runc dependency to app-emulation/docker...
authorManuel Rüger <mrueg@gentoo.org>
Fri, 24 Feb 2017 11:30:16 +0000 (12:30 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Fri, 24 Feb 2017 11:30:41 +0000 (12:30 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-emulation/containerd/containerd-0.2.5-r1.ebuild [new file with mode: 0644]

diff --git a/app-emulation/containerd/containerd-0.2.5-r1.ebuild b/app-emulation/containerd/containerd-0.2.5-r1.ebuild
new file mode 100644 (file)
index 0000000..ce2032d
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+       inherit golang-vcs
+else
+       MY_PV="${PV/_/-}"
+       EGIT_COMMIT="v${MY_PV}"
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc64"
+       inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc2
+       seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+       local options=( $(usex seccomp "seccomp") )
+       export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+       LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+       dobin bin/containerd* bin/ctr
+}