dev-python/aiosmtpd: use HTTPS, add missing die
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Thu, 31 Jan 2019 20:58:23 +0000 (21:58 +0100)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 1 Feb 2019 05:35:58 +0000 (21:35 -0800)
Closes: https://github.com/gentoo/gentoo/pull/10955
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
dev-python/aiosmtpd/aiosmtpd-1.1.ebuild

index 8595ce17c0dbc319c2461a4b5621b443a241a655..dc3132902308d1d74fd7a688bd5245e59db6e32c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -7,18 +7,17 @@ PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
 inherit distutils-r1
 
 DESCRIPTION="asyncio based SMTP server"
-HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
 
 src_prepare() {
-       rm -r examples
+       rm -r examples || die
        distutils-r1_python_prepare_all
 }
index 8595ce17c0dbc319c2461a4b5621b443a241a655..dc3132902308d1d74fd7a688bd5245e59db6e32c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -7,18 +7,17 @@ PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
 inherit distutils-r1
 
 DESCRIPTION="asyncio based SMTP server"
-HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
 
 src_prepare() {
-       rm -r examples
+       rm -r examples || die
        distutils-r1_python_prepare_all
 }