sys-kernel/vanilla-kernel: Bump to 4.19.99
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 14:12:47 +0000 (15:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 18:24:05 +0000 (19:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-kernel/vanilla-kernel/Manifest
sys-kernel/vanilla-kernel/vanilla-kernel-4.19.99.ebuild [new file with mode: 0644]

index 54eb456d0283f17ba086387f5d8a73f5fae10215..3227c7594a23c035997255b87f2f29c618b9e885 100644 (file)
@@ -3,6 +3,7 @@ DIST linux-4.19.92-arch1.amd64.config 222487 BLAKE2B a658d80d85525287a1df9053ca2
 DIST linux-4.19.96.tar.xz 103395480 BLAKE2B 1bc24dd40d427e088e1569be4d5964ae92028ce6ce7e549734837040c5043b5ef4aae572b1430ea5c03f67b7f071e18c4f58a24a63dcb342f18aecf2401ab9a8 SHA512 1fb1ee24429f2183b7e6b85d34e4c88f9c2a82ed95de1b7ca2db3d8ee4815ebcd05cdb171f93e1b0e85f9ffbc3a6fa8c66adceb240d3bf9c38afcc32f21c8dcf
 DIST linux-4.19.97.tar.xz 103398892 BLAKE2B b9e69d52c25ea0d02f61eea31f7d14d109a668c8ec775d1e8f3d0f70527e272172e9cab2b348e5671c466780efe5d16c0c051418bc1b6ad4c508555d9a476a99 SHA512 7988c5ebf453cffa9f89a3fbaa875afc4ca34cbf684158eaeebd1c709ac6224ea8b3581ec5d2ab09aa55ae0e47170ab30dbafb2688cf28456e2e98b6b2ba986a
 DIST linux-4.19.98.tar.xz 103395152 BLAKE2B 622b8f8be3b20f40a0fc4029667077dc0cbb6ce319827967b8749067957af271e1794e1184853351b040a6a1ae5f1a68c769e89db8fe91b3e206d3608bcd89be SHA512 701513873826326cedfc2a1dbb7796f0047f7105bd1cb6478595676b5c3be7be71752398dc3c4a638f0853824ff3426ea9d20448264e1b0c126c3f0eba763ac6
+DIST linux-4.19.99.tar.xz 103405792 BLAKE2B 0e6354dc89f2b8375d16d814377279dcd2df5fced046995c0641548268bb43e973bdeeaf67565c50c5299c670944dc3c9580a372bffc0195fe4492b206fd5267 SHA512 a4275bb56791377e89771b11c5fe12e0607f54a6bffddddc077df629795a88a0cbf332291157c6c88d350f289713d4ce007c90cc5bfdd7c24a7d9020213a3917
 DIST linux-5.4.12.tar.xz 109451372 BLAKE2B f08d30011b2021724a240f45a4d0a92ba01b97d0d2d33ce0d88aeb6dfb0a2e5a532fd55ad0a2ef0e3ec160cb23b351a09b494382e80b0db85bcfe7cfeaa554dd SHA512 d178d775b5d6204b2f53c38ecf81d52141a5520b63e758992c75a59d983e448db2a0c220a17b62588baaad1eda2d9b4a6a86e757f5d50041170559ef6bbc2da0
 DIST linux-5.4.13-arch1.i686.config 239816 BLAKE2B e776321fa163759332e7b5e3cca6a8a3f7124fc7a5bdd498f0aeaec1f2a819f27a87ca6f9f3fb0f0b9f28e8ba6f207bb27c5e48a494664d21ea3845e99b1eab4 SHA512 4e083028a140fcd2e65bba3c39e9d7bf9004e114b3233e8c2ab9e67405a3db9179c10a9564407bf19875317a352453f3e02f137297941277f694e687d3b97674
 DIST linux-5.4.13.arch1.amd64.config 241498 BLAKE2B 3c6d13d84ea75247fae4f4474648abe295fb6ea577d4c9becc58551c3954d35a72edd5937b7bb345f783fe2015940035d5f6766e08e5a9dd6b8723cc69c85ee6 SHA512 3039a333f3000f416bfccd7efdc54c8ea07d9b01b349be87f83b7dcb3e0f13a1f3fb02ccae42412cf28958aa7df42ef73f87e637269c7525476d73682596fa07
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.99.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.99.ebuild
new file mode 100644 (file)
index 0000000..17bfa6e
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux-lts
+AMD64_CONFIG_VER=4.19.92-arch1
+AMD64_CONFIG_HASH=bf97de6a2e405659aaad4c251b7f0bb48d5ed3c9
+# https://git.archlinux32.org/packages/log/core/linux-lts/config
+I686_CONFIG_VER=4.19.85-arch1
+I686_CONFIG_HASH=1f0345e2983d2edd55b401cb5a87fdf365a4192c
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+       amd64? (
+               https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux-lts&id=${AMD64_CONFIG_HASH}
+                       -> linux-${AMD64_CONFIG_VER}.amd64.config
+       )
+       x86? (
+               https://git.archlinux32.org/packages/plain/core/linux-lts/config?id=${I686_CONFIG_HASH}
+                       -> linux-${I686_CONFIG_VER}.i686.config
+       )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+src_prepare() {
+       default
+
+       # prepare the default config
+       case ${ARCH} in
+               amd64)
+                       cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+                       ;;
+               x86)
+                       cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+                       ;;
+               *)
+                       die "Unsupported arch ${ARCH}"
+                       ;;
+       esac
+
+       local config_tweaks=(
+               # shove arch under the carpet!
+               -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+               # we do support x32
+               -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+               # disable signatures
+               -e '/CONFIG_MODULE_SIG/d'
+               -e '/CONFIG_SECURITY_LOCKDOWN/d'
+               # disable compression to allow stripping
+               -e '/CONFIG_MODULE_COMPRESS/d'
+               # disable gcc plugins to unbreak distcc
+               -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
+       )
+       sed -i "${config_tweaks[@]}" .config || die
+}