app-emulation/crun: new ebuild ( 0.10.6 )
authorDan Molik <dan@danmolik.com>
Sun, 10 Nov 2019 10:41:47 +0000 (05:41 -0500)
committerManuel Rüger <mrueg@gentoo.org>
Tue, 19 Nov 2019 12:46:46 +0000 (13:46 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Dan Molik <dan@danmolik.com>
Tested-by: Dan Molik <dan@danmolik.com>
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
app-emulation/crun/Manifest [new file with mode: 0644]
app-emulation/crun/crun-0.10.6.ebuild [new file with mode: 0644]
app-emulation/crun/metadata.xml [new file with mode: 0644]

diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
new file mode 100644 (file)
index 0000000..1652b23
--- /dev/null
@@ -0,0 +1 @@
+DIST crun-0.10.6.tar.gz 1242736 BLAKE2B 840699c6a07ddaef3f6ab4ce226fa6c4ebf0e32641012b6467a2a622d575a48286555b84140d5a1c947b5ef00a691045b0618533fb246bfb6d605baa262febe4 SHA512 b7db09d0c7d2d6e8b1ea239ead5a2ca2b97f188a74f08f0d5ac787e0a698fddf596e7cfdde482c6bc8790d06a7705613e877344a44691c0be7388e6d046c4b15
diff --git a/app-emulation/crun/crun-0.10.6.ebuild b/app-emulation/crun/crun-0.10.6.ebuild
new file mode 100644 (file)
index 0000000..b67e905
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bpf +caps doc seccomp systemd static-libs"
+
+DEPEND="
+       dev-libs/yajl
+       sys-libs/libseccomp
+       caps? ( sys-libs/libcap )
+       seccomp? ( sys-libs/libseccomp )
+       systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+       ${PYTHON_DEPS}
+       doc? ( dev-go/go-md2man )
+"
+
+DOCS=README.md
+
+src_configure() {
+       econf \
+               $(use_enable bpf) \
+               $(use_enable caps) \
+               $(use_enable seccomp) \
+               $(use_enable systemd) \
+               $(usex static-libs '--enabled-shared  --enabled-static' '--enable-shared --disable-static' '' '')
+}
+
+src_compile() {
+       pushd libocispec || die
+       emake
+       popd || die
+       emake crun
+       if use doc ; then
+               emake crun.1
+       fi
+}
+
+src_install() {
+       pushd libocispec || die
+       emake "DESTDIR=${D}" install-exec
+       popd || die
+       emake "DESTDIR=${D}" install-exec
+       if use doc ; then
+               emake "DESTDIR=${D}" install-man
+       fi
+
+       # there is currently a bug in upstream autotooling that continues to build static libraries despite
+       # explicit configure options
+       use static-libs || find "${ED}"/usr -name '*.la' -delete
+
+       einstalldocs
+}
diff --git a/app-emulation/crun/metadata.xml b/app-emulation/crun/metadata.xml
new file mode 100644 (file)
index 0000000..1b7e66c
--- /dev/null
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>dan@danmolik.com</email>
+               <name>Dan Molik</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription lang="en">
+               While most of the tools used in the Linux containers ecosystem are written in
+               Go, crun authors believe C is a better fit for a lower level tool like a
+               container runtime. runc; the most used implementation of the OCI runtime specs
+               written in Go, re-execs itself and use a module written in C for setting up
+               the environment before the container process starts.
+
+               crun aims to be also usable as a library that can be easily included in
+               programs without requiring an external process for managing OCI containers.
+       </longdescription>
+       <upstream>
+               <changelog>https://github.com/containers/crun/releases</changelog>
+               <remote-id type="github">containers/crun</remote-id>
+       </upstream>
+       <use>
+               <flag name="bpf">Enable in Kernel, eBPF (enhanced Berkley Packet Filter)
+                       support for managing device controllers.
+               </flag>
+       </use>
+</pkgmetadata>