gnome-base/gnome-desktop: bump to 3.26.2
authorMart Raudsepp <leio@gentoo.org>
Fri, 14 Dec 2018 18:22:42 +0000 (20:22 +0200)
committerMart Raudsepp <leio@gentoo.org>
Fri, 14 Dec 2018 19:01:44 +0000 (21:01 +0200)
Also force seccomp when available, or configure fails. This is not
patched to be optional on purpose - this kind of security is NOT
optional as far as I'm concerned.

Compared to gnome overlay version, this one:

* adds a big patchset for more sandboxed thumbnailing fixes,
  memory leak fixes and other misc changes that don't break ABI
* patch to hopefully fix thumbnailing on non-seccomp architectures
  (bwrap was still enabled, leading to broken runtime as bwrap
  requires seccomp)
* RDEPENDs on sys-apps/bubblewrap with seccomp as required
* removes USE=dbus dep on glib
* revbumps over overlay revision to ensure upgrades

Closes: https://bugs.gentoo.org/653786
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.52, Repoman-2.3.11

gnome-base/gnome-desktop/Manifest
gnome-base/gnome-desktop/gnome-desktop-3.26.2-r2.ebuild [new file with mode: 0644]
profiles/base/package.use.force

index e96b392122b88d598d111bd3df74ee0164c3d4fc..04014ad7164da269ad88f3ce756878c550303169 100644 (file)
@@ -1,2 +1,4 @@
 DIST gnome-desktop-2.32.1.tar.bz2 1633847 BLAKE2B 9c69504b0f904fe04bdaa2e2fd3c6fbdd0cdd67033bae6e21377cce2deb68f05ed85bc735547c036923978ebdb8952c262676a01a33f8d7acffb0b964f97366a SHA512 b8084d08366dab661a7ee369cd03ba62beddbdfa9a36b988b7d13d207b33d6916f7fa8691717fba7b6a70d8276779e35360b1dc385e6ec876f30ea7b8b373c28
 DIST gnome-desktop-3.24.2.tar.xz 1064808 BLAKE2B 8574d26f2c2adedd7a287651fb34170e75d1744ad14e6caab8ede87af63b93197bcf4cde60dd9f6352dae8ae7bf8d598d0b24588d3a06cc2192c651b58577562 SHA512 691817fda97fc1c560c72213668eb4c2a8d03cc2433470a78149b3f785e95d9b4b681bceb733a67e1bfda649a6aed7ca4569b4891ee89f824a28d7a95f2782c2
+DIST gnome-desktop-3.26.2-patchset.tar.xz 13220 BLAKE2B cbcd78a9221ef2267c89888156346cec836000e9fda68bcdfe7d57712e40c351af3bf4f4e75a1f62e433ac3ace2730e48188dde9668c0666c2bd69a032dc3a3d SHA512 390448cc8aaf4f5885323e3fe60385fdfe28784764a8fb5bdaff7a34ba34cbfd7a1016228d11bf2c50b843580b9983cfc675e2ba8d64e66faf2711192ab45c38
+DIST gnome-desktop-3.26.2.tar.xz 969500 BLAKE2B fb1e671d8fb890d9aabbd351b824b76f13ed7ba62dd3f82a36fca7cbe590af8901fc7bd8ef1be6a5c9b978569b306eba5c3d2f9545856389438a43539b1ed9e4 SHA512 1425bead81a63d9d19f09fb8d23cd2611645898a910887c2b6a672bfbec3dd956e29e1d8c5f941d06929febc7734dec0550f7a15336583fcf9be41f1a4e9c783
diff --git a/gnome-base/gnome-desktop/gnome-desktop-3.26.2-r2.ebuild b/gnome-base/gnome-desktop/gnome-desktop-3.26.2-r2.ebuild
new file mode 100644 (file)
index 0000000..554b769
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+inherit gnome2 virtualx
+
+DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
+HOMEPAGE="https://git.gnome.org/browse/gnome-desktop"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="3/12" # subslot = libgnome-desktop-3 soname version
+IUSE="debug +introspection seccomp udev"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sh ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+# cairo[X] needed for gnome-bg
+COMMON_DEPEND="
+       app-text/iso-codes
+       >=dev-libs/glib-2.53.0:2
+       >=x11-libs/gdk-pixbuf-2.36.5:2[introspection?]
+       >=x11-libs/gtk+-3.3.6:3[X,introspection?]
+       x11-libs/cairo:=[X]
+       x11-libs/libX11
+       x11-misc/xkeyboard-config
+       >=gnome-base/gsettings-desktop-schemas-3.5.91
+       introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+       seccomp? ( sys-libs/libseccomp )
+       udev? (
+               sys-apps/hwids
+               virtual/libudev:= )
+"
+RDEPEND="${COMMON_DEPEND}
+       !<gnome-base/gnome-desktop-2.32.1-r1:2[doc]
+       seccomp? ( sys-apps/bubblewrap )
+"
+DEPEND="${COMMON_DEPEND}
+       app-text/docbook-xml-dtd:4.1.2
+       dev-util/gdbus-codegen
+       >=dev-util/gtk-doc-am-1.14
+       >=dev-util/intltool-0.40.6
+       dev-util/itstool
+       sys-devel/gettext
+       x11-base/xorg-proto
+       virtual/pkgconfig
+       app-text/yelp-tools
+" # app-text/yelp-tools for eautoreconf
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xorg-proto
+
+PATCHES=(
+       "${WORKDIR}"/patches/ # Requires eautoreconf. Various backports for sandboxed thumbnailer, leak fixes and more - https://gitlab.gnome.org/Community/gentoo/gnome-desktop/commits/gentoo-3.26.2
+)
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               --with-gnome-distributor=Gentoo \
+               --enable-desktop-docs \
+               $(usex debug --enable-debug=yes ' ') \
+               $(use_enable debug debug-tools) \
+               $(use_enable introspection) \
+               $(use_enable udev)
+}
+
+src_test() {
+       virtx emake check
+}
index 02bbed529b2284057c6825e810c7e4717b87e3df..de377b60ee95d9c8b3bdf18e3930cbfda9e2f460 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+# Mart Raudsepp <leio@gentoo.org> (14 Dec 2018)
+# Security is not optional if available for the architecture/kernel.
+gnome-base/gnome-desktop seccomp
+
 # Andreas K. Hüttel <dilfridge@gentoo.org> (11 Sep 2018)
 # All glibc versions that include RPC code are masked now.
 dev-libs/libspt libtirpc