media-sound/ezstream: fix taglib detection
authorSteffen 'j0inty' Stollfuß <j0inty@fairnatics.net>
Sun, 3 Sep 2017 05:55:35 +0000 (15:55 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 3 Sep 2017 05:56:28 +0000 (15:56 +1000)
Gentoo-bug: 596376
Package-Manager: Portage-2.3.6, Repoman-2.3.3

media-sound/ezstream/ezstream-0.6.0-r1.ebuild [new file with mode: 0644]

diff --git a/media-sound/ezstream/ezstream-0.6.0-r1.ebuild b/media-sound/ezstream/ezstream-0.6.0-r1.ebuild
new file mode 100644 (file)
index 0000000..59af61c
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A command line source client for Icecast media streaming servers"
+HOMEPAGE="http://www.icecast.org/ezstream/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="taglib"
+
+COMMON_DEPEND="dev-libs/libxml2
+       >=media-libs/libshout-2.2
+       !taglib? ( media-libs/libvorbis )
+       taglib? ( media-libs/taglib )"
+RDEPEND="${COMMON_DEPEND}
+       net-misc/icecast"
+DEPEND="${COMMON_DEPEND}
+       virtual/pkgconfig"
+
+src_configure() {
+       local docdir=/usr/share/doc/${PF}
+
+       econf \
+               --docdir=${docdir} \
+               --enable-examplesdir=${docdir}/examples \
+               $(use_with taglib taglib "/usr")
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+       rm -f "${D%/}"/usr/share/doc/${PF}/COPYING
+}