sci-mathematics/diagrtb: EAPI 6
authorJohannes Huber <johu@gentoo.org>
Sat, 11 Feb 2017 22:35:58 +0000 (23:35 +0100)
committerJohannes Huber <johu@gentoo.org>
Sat, 11 Feb 2017 22:35:58 +0000 (23:35 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-mathematics/diagrtb/diagrtb-2.64.ebuild

index 1283039df7eb834bffa3d04d8630f6dec5d792b2..27c9262aa64e2a71f38f1611e6445b2fe8efb268 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=4
+EAPI=6
 
 inherit cmake-utils fortran-2
 
@@ -20,11 +20,14 @@ S="${WORKDIR}"/Source_RTB2011
 
 src_prepare() {
        cp "${FILESDIR}"/CMakeLists.txt . || die
+
+       cmake-utils_src_prepare
 }
 
 src_configure() {
-       mycmakeargs=(
-               $(cmake-utils_use examples EXAMPLES)
+       local mycmakeargs=(
+               -DEXAMPLES=$(usex examples)
        )
+
        cmake-utils_src_configure
 }